POJ 1511-Invitation Cards(双向最短路)

Invitation Cards
Time Limit: 8000MS Memory Limit: 262144K
Total Submissions: 30946 Accepted: 10307

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

Source

题目大意:一个人初始位置在1,每天早上他要去2~n的每个地方,晚上又要从这些地方回到位置1,求他这一天坐车的最小总花费,题目中的时间与解题并没有什么关系。
解题思路: 显然我们可以通过最短路来解决这一题,但是由于车程是单向的,对于回来的路线我们似乎要求出其他每个点到位置1的最短路线,似乎比较麻烦,不过我们有个小技巧可以很快的解决这个问题,在建图时,我们可以建两个图,一个存正常路线 ,一个存反向的,这样我们求回去的路线不就又成了求一次位置1到其他点的最短路,最后我们所有的距离加起来不就是总花费。(还有,距离注意开longlong

AC代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<math.h>
#include<string.h>
typedef long long ll;
using namespace std;
const int mod = 10;
const int N = 1000010;
const int INF = 1e9;
typedef pair<long long, int> par;

int n, m;
int cnt, cnt2, head[N], head2[N];
long long d[N], D[N], ans;

struct edge
{
    int end;
    ll len;
    int next;
}e[1000005] ,e2[1000005]; //一个存正常,一个存反向

void add_edge(int u, int v, int w) //我们用邻接表来建图
{
    e[cnt].end = v;
    e[cnt].len = w;
    e[cnt].next = head[u];
    head[u] = cnt ++;
    e2[cnt2].end = u;
    e2[cnt2].len = w;
    e2[cnt2].next = head2[v];
    head2[v] = cnt2 ++;
}

void dijstra()
{
    for(int i = 1; i <= n; i ++) {
            d[i] = INF;
            D[i] = INF;
    }
    d[1] = 0;
    D[1] = 0;
    priority_queue< pair<long long, int> > q;
    q.push(make_pair(0, 1));
    while(!q.empty()) {  //正常的最短路
        par cur;
        cur = q.top();
        q.pop();
        long long a = -cur.first;
        int b = cur.second;
        for(int i = head[b]; i != -1; i = e[i].next) {
            int en = e[i].end;
            long long len = a + e[i].len;
            if(d[en] > len) {
                d[en] = len;
                q.push(make_pair(-len, en));
            }
        }
    }
    q.push(make_pair(0, 1));
    while(!q.empty()) {  //反向的最短路
        par cur;
        cur = q.top();
        q.pop();
        long long a = -cur.first;
        int b = cur.second;
        for(int i = head2[b]; i != -1; i = e2[i].next) {
            int en = e2[i].end;
            long long len = a+e2[i].len;
            if(D[en] > len) {
                D[en] = len;
                q.push(make_pair(-len, en));
            }
        }
    }
}

int main()
{
    int T, x, y, z;
    scanf("%d", &T);
    while(T --) {
        cnt = cnt2 = 0;
        ans = 0;
        memset(head, -1, sizeof(head));
        memset(head2, -1, sizeof(head2));
        scanf("%d%d", &n, &m);
        for(int i = 0; i < m; i ++) {
            scanf("%d%d%d", &x, &y, &z);
            add_edge(x, y, z);
        }
        dijstra();
        for(int i = 2; i <= n; i ++) { //总费用
            ans += d[i];
            ans += D[i];
        }
        printf("%lld\n", ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值