HDU 1541-Stars(单点更新+区间查询)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11809    Accepted Submission(s): 4682


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
 
 
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
 
 
1 2 1 1 0
 

Source
 

题目大意:计算出每种等级星星的数量,某个星星的等级定义为:图中x,y的坐标于都小等于该星星的其他星星的数量。

解题思路:题目中给出的数据方式为:按照每个星星的y坐标从小到大给出,y坐标相等的按照x的坐标从小到大给出,这样一来就直接可以在输入坐标时进行统计了,因为对于每个输入的星星,只有前面输入的星星的y坐标小于等于该星星,所以只需要统计前面输入的星星中有多少星星的x坐标小于当前星星的x坐标即可,这样我们就把这个问题转化成了线段树或者树状数组单点更新+区间查询的问题了。下面给出树状数组代码,线段树太冗长了。。。

AC代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
#include<math.h>
#include<stdlib.h>
#include<queue>
#include<map>
#include<set>
#define bug printf("*********\n");
#define mem0(a) memset(a, 0, sizeof(a));
#define mem1(a) memset(a, -1, sizeof(a));
#define in1(a) scanf("%d" ,&a);
#define in2(a, b) scanf("%d%d", &a, &b);
#define out1(a) printf("%d\n", a);
#define out2(a, b) printf("%d %d\n", a, b);
using namespace std;
typedef long long LL;
typedef pair<int, int> par;
const int mod = 1e9+7;
const int INF = 1e9+7;
const int N = 1000010;
const double pi = 3.1415926;

int n, bit[32010], a[32010];

int sum(int i)
{
    int ans = 0;
    while(i > 0) {
        ans += bit[i];
        i -= (i&-i);
    }
    return ans;
}

void add(int i, int x)
{
    while(i <= 32010) {
        bit[i] += x;
        i += (i&-i);
    }
}

int main()
{
    int x, y;
    while(~scanf("%d", &n)) {
        mem0(bit);
        mem0(a);
        for(int i = 0; i < n; i ++) {
            scanf("%d%d", &x, &y);
            a[sum(x+1)] ++; //对坐标我们处理下,因为x会=0,所以我们后移一位
            add(x+1, 1); //注意先统计再加
        }
        for(int i = 0; i < n; i ++)
            out1(a[i]);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值