HDU 3038-How Many Answers Are Wrong(带权并查集)

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13220    Accepted Submission(s): 4684


Problem Description
TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
 

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
 

Output
A single line with a integer denotes how many answers are wrong.
 

Sample Input
 
 
10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
 

Sample Output
 
 
1
 

Source
 

题目大意:给你一个n个数的数组,有m个已知条件,让你按顺序来判断有多少个条件是错误的,每个条件的意思是:从数组a-b的和为c。

解题思路:怎么说呢,这个带权并查集似乎就是,把相邻的区间(就是[a, b-1]和[b, c]这样的,必须有一个点严格相邻)放到一个集合里面,进行查询,这里还用到了一个sum数组,这个数组装的是区间,sum[a] = [fa, a]的值,注意这个值是有方向的,正向的就为正,反向的就为负值,这样就形成了一个带权的并查集,一个区间就是一条边,边权就是这个区间的值。

对于条件正确与否的判断其实就是对应区间值是否相同的判断:这个只有在有相同的父节点(区间相邻)的时候才进行判断,例如输入,x, y, z表示[x, y] = z,如果有相同的父节点k的话,那么sum[y] - sum[x] = [k, y] - [k, x] = [x, y],这个和前缀和数组很相似。

如果不在同一个集合的话,我们就合并,合并的操作其实也是一个道理,分别找到两个集合对应的父节点,然后root[fy] = fx,继续更新sum[fy] = [fx, fy],也就是代码中的,sum[fy] = sum[x] - sum[y] + z = sum[fx, x] - sum [fy, y] + sum[x, y] = sum[fx, y] - sum[fy, y] = sum[fx, fy]。

看完后你会发现这个sum真的就是一个前缀和数组。这样就不需要我解释代码中的x --的操作了吧,自己用心体会下吧。

AC代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
#include<math.h>
#include<stdlib.h>
#include<queue>
#include<map>
#include<set>
#include<stack>
#define bug printf("*********\n");
#define mem0(a) memset(a, 0, sizeof(a));
#define mem1(a) memset(a, -1, sizeof(a));
#define finf(a, n) fill(a, a+n, INF);
#define in1(a) scanf("%d" ,&a);
#define in2(a, b) scanf("%d%d", &a, &b);
#define in3(a, b, c) scanf("%d%d%d", &a, &b, &c);
#define out1(a) printf("%d\n", a);
#define out2(a, b) printf("%d %d\n", a, b);
#define pb(G, a, b) G[a].push_back(b);
using namespace std;
typedef long long LL;
typedef pair<int, int> par;
const int mod = 1e9+7;
const int INF = 1e9+7;
const int N = 1000010;
const double pi = 3.1415926;

int n, m;
int root[200010], sum[200010];

int find_root(int k)
{
    if(k!= root[k]) {
        int tem = root[k];
        root[k] = find_root(root[k]);
        sum[k] += sum[tem]; //移动子节点的时候要更新权值
    }
    return root[k];
}

int main()
{
    int x, y, z;
    while(~scanf("%d%d", &n, &m)) {
        int ans = 0;
        for(int i = 0; i <= n; i ++) 
            root[i] = i;
        mem0(sum);
        for(int i = 0; i< m; i ++) {
            scanf("%d%d%d", &x, &y, &z);
            x --;
            int fx = find_root(x);
            int fy = find_root(y);
            if(fx != fy) { //不在同一个集合
                root[fy] = fx;
                sum[fy] = sum[x] - sum[y] + z;
            }else { //在同一个集合
                if(sum[y] - sum[x] != z)
                    ans ++;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值