PAT甲级-1015 Reversible Primes (20)(20 分)【判断素数+反过来转化成其他进制】

1015 Reversible Primes (20)(20 分)

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 10^5^) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

解题思路:

素数判断的时候,i<=sqrt(n)这句,我一开始交的时候没有打等于号,错了一个测试点,如果不能理解,那就把73转化成37时写的代码中把10改成d就好了。在反转用do-while比较好,这样等于0的时候就不用单独讨论了。

#include<bits/stdc++.h>
using namespace std;
int Reversible(int n,int d)
{
	int sum=0;
	do{
		sum=sum*d+n%d;
		n=n/d;
	}while(n!=0);
	return sum; 
}
int is_prime(int n)
{
	if(n==0||n==1)
	return 0;
	for(int i=2;i<=sqrt(n);i++)
	{
		if(n%i==0) return 0;
	}
	return 1;
}
int main(void)
{
	int n,d;
	while(~scanf("%d%d",&n,&d)&&n>=0)
	{
		//cout<<Reversible(n,d)<<endl;
		if(is_prime(n)&&is_prime(Reversible(n,d)))
		cout<<"Yes"<<endl;
		else
		cout<<"No"<<endl;
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值