进制转换+可逆质数 1015 Reversible Primes (20分)

1015 Reversible Primes (20分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10
​5
​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

解题
给数N和进制D,求把N转为D进制之后逆序,再转回十进制,是否为质数;
若N和进制转换+逆序+进制转会后的数都为质数,输出Yes;

1.质数判断

#include<iostream>
#include<string>
using namespace std;

bool isprime(int n)
{
	if(n==1) return false;
	for(int i=2;i*i<=n;i++)
		if(n%i==0) return false;
	return true;
}

2.将N转换成D进制,逆序后再转回十进制;

int radixchange(int n, int radix)   //反向之后再回来 
{
	string tmp="";
	int t=1;
	while(n>0)
	{
		tmp+=char(n%radix);
		n/=radix;
	}
	int res=0;
	for(int i=0;i<tmp.size();i++)
		res=res*radix+int(tmp[i]);
			
	return res;
}

3.按要求输出

int N,D;
int main()
{
	int tmp;
	while(cin>>N)
	{	
		if(N<0) break;
		cin>>D;
		tmp=radixchange(N,D);    //N转化为D进制
		//D进制reverse再转化为十进制,再判断 
		if(isprime(N)&&isprime(tmp)) cout<<"Yes"<<endl;
		else cout<<"No"<<endl;
	}
	return 0;
}

总结
1.十进制转D进制——每一位为N%D,N/=D 从右往左填;
2.D进制转十进制——从左往右,sum=sum*D+N[i]%10;

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值