A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index
, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
题意:有n个点,接下来输入n行(0-n-1)表示左孩子有孩子节点,如果-1表示没有,最后一行输入9个数字,按照上面这棵树的样子将这9个数按照二叉搜索树填进去,最后输出填进去后的层序遍历的结果。
解题思路:二叉搜索树的中序遍历就是结点值从小到大排序的结果,根据这个性质解决这题。我们用结构体存储左右孩子以及结点值,接下来就是中序遍历,中序遍历中将结点值填进去,然后是层序遍历,用一个数组保存层序遍历的结点值就ok了,具体的见代码。
#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
vector<int>in,level,key;
int index=0;
struct Avl{
int data,l,r;
}v[110];
void inOrder(int root)
{
if(v[root].l!=-1) inOrder(v[root].l);
v[root].data=key[index++];
if(v[root].r!=-1) inOrder(v[root].r);
}
void levelOrder(int root)
{
queue<int>q;
q.push(root);
while(!q.empty())
{
int cur=q.front();
q.pop();
level.push_back(v[cur].data);
if(v[cur].l!=-1) q.push(v[cur].l);
if(v[cur].r!=-1) q.push(v[cur].r);
}
}
int main(void)
{
int n,root=0,l,r;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d %d",&v[i].l,&v[i].r);
}
key.resize(n);
for(int i=0;i<n;i++)
scanf("%d",&key[i]);
sort(key.begin(),key.end());
inOrder(root);
levelOrder(root);
for(int i=0;i<n;i++)
printf("%d%s",level[i],i==n-1?"\n":" ");
return 0;
}