1099 Build A Binary Search Tree(30 分)

1099 Build A Binary Search Tree(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

 

emmm这题就是根据给定的哪些固定的点建立二叉搜索树

因为是二叉搜索树 中序就是从小到大顺序输出的.........所以 同理,砸门也可以反着来 既然中序可以输出从小到大  那么也就是说 从小到大也可以建立一个树 神奇 本来我这个点也是懵懵的 之前做过一题 这边也是不懂  刚刚去模拟了一下发现是这样子嘿嘿

 

 

代码

#include<bits/stdc++.h>
using namespace std;
struct Node
{
	int data;
	int left,right;	
}root[105];
int digit[105],now = 0;
void Inorder(int x)
{
	if(root[x].left != -1)
		Inorder(root[x].left);
	root[x].data = digit[now++];
	if(root[x].right != -1)
		Inorder(root[x].right);
}//中序建立二叉搜索树 
int main()
{
	int n,x,y;
	scanf("%d",&n);
	for(int i = 0; i < n ; i++ )
		scanf("%d%d",&root[i].left,&root[i].right);	
	for(int i = 0 ; i < n; i++)
		scanf("%d",&digit[i]);
	sort(digit,digit+n);
	Inorder(0);
	queue<Node>qu;//	接下来是层序遍历了
	qu.push(root[0]);
	vector<int>vec;
	while(qu.empty() == 0)
	{
		Node tmp = qu.front();
		qu.pop();
		vec.push_back(tmp.data);
		if(tmp.left != -1)
			qu.push(root[tmp.left]);
		if(tmp.right != -1)
			qu.push(root[tmp.right]);
	} 
	for(int i = 0 ; i < n; i++)
		printf("%d%c",vec[i]," \n"[i==n-1]);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值