PTA甲级 1099 Build A Binary Search Tree (30分) 树的遍历

强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解
算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

生词如下:

没有

题目大意:

就是给你一个二叉树的序列.然后再给你一堆数据,要你按照这个序列,成为一个二叉搜索树.

思路如下:

就只要遍历一遍就够了.

我这里用的是中序遍历.因为中序遍历是有序的.

然后再把插入的数据,直接算在层次里.leve[110]里面

然后输出level即可

代码如下:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct node {
	int data, left, right;
};
vector<node> v;
vector<int> put,level[110];
int n=0,t=0,index=0;
void inOrder(int root,int depth) {
	if (v[root].left == -1);
	else inOrder(v[root].left,depth+1);
	level[depth].push_back(put[index++]);
	sort(level[depth].begin(), level[depth].end());
	if (v[root].right == -1);
	else inOrder(v[root].right, depth + 1);
 }
int main(void) {
	scanf("%d", &n);
	v.resize(n); put.resize(n);
	for (int i = 0; i < n; ++i) scanf("%d %d", &v[i].left, &v[i].right);
	for (int i = 0; i < n; ++i)	scanf("%d", &put[i]);
	sort(put.begin(), put.end());
	inOrder(0,0);
	for (int i = 0; i < 110; i++) {
		if (level[i].size() == 0)	break;
		for (int j = 0; j < level[i].size(); ++j) {
			printf("%d", level[i][j]);
			if (j == level[i].size() - 1 && level[i + 1].size() == 0);
			else printf(" ");
		}
	}
	return 0;
}

柳神的思路

分析:1. 用结构体data,left,right,index,level表示这棵树的结构,a数组存树的信息,b数组存这棵树节点的所有data,根据输入可知树a[i]的left和right~
\2. 因为是二叉搜索树,所以中序遍历这棵树得到的结点顺序应该是给出的数值序列从小到大的排列顺序,所以把数值序列排序后,可以在中序遍历的时候直接赋值当前tree[root].data~
\3. 然后根据节点的层数和下标,就可以排序输出层序了~

柳神的代码:

#include <iostream>
#include <algorithm>
using namespace std;
int n, cnt, b[100];
struct node {
    int data, l, r, index, lebel;
}a[110];
bool cmp(node x, node y) {
    if (x.lebel != y.lebel) return x.lebel < y.lebel;
    return x.index < y.index;
}
void dfs(int root, int index, int lebel) {
    if (a[root].l == -1 && a[root].r == -1) {
        a[root] = {b[cnt++], a[root].l, a[root].r, index, lebel};
    } else {
        if (a[root].l != -1) dfs(a[root].l, index * 2 + 1, lebel + 1);
        a[root] = {b[cnt++], a[root].l, a[root].r, index, lebel};
        if (a[root].r != -1) dfs(a[root].r, index * 2 + 2, lebel + 1);
    }
}
int main() {
    cin >> n;
    for (int i = 0; i < n; i++)
        cin >> a[i].l >> a[i].r;
    for (int i = 0; i < n; i++)
        cin >> b[i];
    sort(b, b + n);
    dfs(0, 0, 0);
    sort(a, a + n, cmp);
    for (int i = 0; i < n; i++) {
        if (i != 0) cout << " ";
        cout << a[i].data;
    }
    return 0;
}

如果这篇文章对你有张帮助的话,可以用你高贵的小手给我点一个免费的赞吗

相信我,你也能变成光.

在这里插入图片描述

如果你有任何建议,或者是发现了我的错误,欢迎评论留言指出.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值