1127 ZigZagging on a Tree (30 分)
Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
题意:给出后序和中序,输出层序遍历的结果(s型)
解题思路:跟先序转换差不多,先序是先左后右,所以先序得到的层序是从左往右,所以呢,可以用二维数组level存储层序遍历的结果,第一次运行的时候没看清题目,应该先输出根节点(第0层),从第一层开始从左到右,第二层从右到左 ,以此类推,也就是层数%2==1的从j=0到就j<level[i].size(),否则就是反过来,从后往前,具体的见代码
#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>level[35],post,pre,in;
int maxlev=-1;
void preorder(int root,int start,int end,int index,int lev)
{
if(start>end) return;
if(lev>maxlev) maxlev=lev;
int i=start;
while(i!=end&&in[i]!=post[root]) i++;
level[lev].push_back(post[root]);
preorder(root-1+i-end,start,i-1,2*index+1,lev+1);
preorder(root-1,i+1,end,2*index+2,lev+1);
}
int main(void)
{
int n;
scanf("%d",&n);
post.resize(n);
in.resize(n);
for(int i=0;i<n;i++)
scanf("%d",&in[i]);
for(int i=0;i<n;i++)
scanf("%d",&post[i]);
preorder(n-1,0,n-1,0,0);
printf("%d",level[0][0]);
for(int i=1;i<=maxlev;i++)
{
if(i%2==1)
for(int j=0;j<level[i].size();j++)
{
printf(" %d",level[i][j]);
}
else
for(int j=level[i].size()-1;j>=0;j--)
{
printf(" %d",level[i][j]);
}
}
return 0;
}