PAT甲级1127

1127. ZigZagging on a Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

#include<cstdio>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 35;
int in[maxn], post[maxn];
struct Node
{
	int data;
	int depth;
	Node*l, *r;
	Node():l(NULL),r(NULL){}
};
int N, maxdepth = -1;
Node*create(int i1, int i2, int p1, int p2)
{
	if (i1 > i2 || p1 > p2)return NULL;
	Node*root = new Node();
	root->data = post[p2];
	int k;
	for (int i = i1; i <= i2; i++)
	{
		if (in[i] == root->data)
		{
			k = i; break;
		}
	}
	root->l = create(i1, k - 1, p1, p1 + k - 1 - i1);
	root->r = create(k+1, i2, p2-1-(i2-k-1), p2-1);
	return root;
}
vector<int> nodes[maxn];
void BFS(Node*root)
{
	queue<Node*>Q;
	root->depth = 0;
	Q.push(root);
	while (!Q.empty())
	{
		Node*f = Q.front();
		Q.pop();
		maxdepth = max(maxdepth, f->depth);
		nodes[f->depth].push_back(f->data);
		if (f->l)
		{
			f->l->depth = f->depth + 1;
			Q.push(f->l);
		}
		if (f->r)
		{
			f->r->depth = f->depth + 1;
			Q.push(f->r);
		}
	}
}
int main()
{
	scanf("%d", &N);
	for (int i = 0; i < N; i++)
		scanf("%d", &in[i]);
	for (int i = 0; i < N; i++)
		scanf("%d", &post[i]);
	Node*root = NULL;
	bool first = true;
	root = create(0, N - 1, 0, N - 1);
	BFS(root);
	for (int i = 0; i <= maxdepth; i++)
	{
		if (i % 2 == 0)
		{
			for (int j = 0; j < nodes[i].size(); j++)
			{
				if (first)
				{
					first = false;
					printf("%d", nodes[i][nodes[i].size() - 1 - j]);
				}
				else printf(" %d", nodes[i][nodes[i].size() - 1 - j]);
			}
		}
		else
		{
			for (int j = 0; j < nodes[i].size(); j++)
			{
				if (first)
				{
					first = false;
					printf("%d", nodes[i][j]);
				}
				else printf(" %d", nodes[i][j]);
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值