C++学习之路 | PTA(甲级)—— 1127 ZigZagging on a Tree (30分)(带注释)(精简)

1127 ZigZagging on a Tree (30分)
Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
zigzag.jpg
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:

1 11 5 8 17 12 20 15

#include<iostream>
#include<vector>
#include<queue>
#include<stack>//需要调转顺序,想到使用栈
using namespace std;
const int maxn = 30;
int n;
int post[maxn]{ 0 };//存储后序遍历的数组
int in[maxn]{ 0 };//存储中序遍历的数组
struct node {
	int data;
	node* left;
	node* right;
};
struct node* create(int post_l, int post_r, int in_l, int in_r)//后序遍历的第一个节点,最后一个节点,中序遍历的第一个节点,最后一个节点
{
	if (post_l > post_r)
	{
		return nullptr;
	}
	struct node* root = new node();
	root->data = post[post_r];//根节点为后序遍历最后一个节点
	root->left = nullptr;
	root->right = nullptr;
	int i = in_l;
	for (i; i < in_r; i++)//寻找根节点在中序遍历的位置
	{
		if (in[i] == post[post_r])
		{
			break;
		}
	}
	root->left = create(post_l, post_l + i - in_l - 1, in_l, i - 1);
	root->right = create(post_l + i - in_l, post_r-1, i + 1, in_r);
	return root;
}
void level(node* root)//层序遍历
{
	queue<node*>q;
	if (root)
		q.push(root);
	int flag = 0;//利用flag进行输出的顺序调转
	int first = root->data;
	while (!q.empty())
	{
		int length = q.size();//因为需要进行调转,一次需要将队列的值全部输出
		if (flag==1)
		{
			for (int i = 0; i < length; i++)
			{
				node* value = q.front();
				q.pop();
				cout << " " << value->data;//输出
				if (value->left)q.push(value->left);//左孩子入队
				if (value->right)q.push(value->right);//右孩子入队
			}
			flag = 0;//标记更换
		}
		else
		{
			stack<int>s;//如果需要从后向前输出,利用栈
			for (int i = 0; i < length; i++)
			{
				node* value = q.front();
				q.pop();
				s.push(value->data);
				if (value->left)q.push(value->left);
				if (value->right)q.push(value->right);
			}
			while (!s.empty())//清栈
			{
				int t = s.top();
				s.pop();
				if (t == first)cout << t;
				else cout << " " << t;
			}
			flag = 1;
		}

	
	}
}
int main()
{
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> in[i];
	}
	for (int i = 0; i < n; i++)
	{
		cin >> post[i];
	}
	node* root=create(0, n - 1, 0, n - 1);//建树
	level(root);//层序遍历输出
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值