POJ 1860:Currency Exchange (spfa 判环)

 Currency Exchange
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular 
currencies and performs exchange operations only with these currencies. There can be several points specializing in the
 same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 
1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission
 is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange
rate  is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number 
from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of 
c urrencies it exchanges, and real R  AB , C AB , R  BA  and C  BA  - exchange rates and commissions when exchanging A to B
 and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital.
 Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must 
always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, 
S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 
numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated 
by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10  3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 
10  -2<=rate<=10  2, 0<=commission<=10  2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. 
You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the 
exchange operations will be less than 10  4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
 
   
 
   
<------------------------------------------------------------------------------>
题意:有 n 种钱币,m 种兑换方式,Nick 拥有 v 个单位的 s 号钱币,问经过多次兑换钱币之后
    (要求最后的币种依然为 s 号钱币),钱币的值能否增加。
r_ab 表示钱币A->B的利率;
c_ab 表示钱币A->B需要支付的手续费(反之 r_ba 和 c_ba 也一样理解)


思路:直接用 spfa 算法判环(某个点入队次数超过点个数 n 即存在正(负)环)
 
   
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
#define N 120
int n, m, s, t, vis[N], judge[N], head[N];
double rate, com, v, dis[N];
struct edge
{
	int s, d, next;
	double r, c;
}e[N*N];
void add(int i, int j, double r, double c)
{
	e[t].s=i;
	e[t].d=j;
	e[t].r=r;
	e[t].c=c;
	e[t].next=head[i];
	head[i]=t++;
}
bool spfa(int s)
{
	int i, j, out;
	queue<int> q;
	q.push(s);
	vis[s]=judge[s]=1;
	dis[s]=v;
	while(!q.empty())
	{
		out=q.front(); q.pop();
		vis[out]=0;
		for(i=head[out];i!=-1;i=e[i].next){
			if((dis[out]-e[i].c)*e[i].r > dis[e[i].d]&&(dis[out]-e[i].c)>=0)
                        {
				dis[e[i].d]=(dis[out]-e[i].c)*e[i].r;
				if(!vis[e[i].d]){
                                   q.push(e[i].d);
				   vis[e[i].d]=1; 
				   judge[e[i].d]++;
                                }
				if(judge[e[i].d]>n)  return true; //<span style="font-family: 'Courier New', Courier, monospace; font-size: 12pt; white-space: pre-wrap;">判环</span>
			}
		}
	}
	return false;
}
int main()
{
#ifdef OFFLINE
	freopen("t.txt", "r", stdin);
#endif
	int i, j, k, a, b;
	double r_ab, c_ab, r_ba, c_ba;
	while(~scanf("%d%d%d%lf", &n, &m, &s, &v))
	{
		t=0;
		memset(vis, 0, sizeof(vis));
		memset(judge, 0, sizeof(judge));
		memset(dis, 0, sizeof(dis));
		memset(head, -1, sizeof(head));
		for(i=0;i<m;++i){
			scanf("%d%d%lf%lf%lf%lf", &a, &b, &r_ab, &c_ab,&r_ba,&c_ba);
			add(a, b, r_ab, c_ab);
			add(b, a, r_ba, c_ba);
		}
		if(spfa(s))
			printf("YES\n");
		else
			printf("NO\n");
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值