Catch That Cow


Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>


using namespace std;


int dir[3]= {1,-1};


struct node
{
    int x,step;
} s,ss;


int bfs(int n,int k)
{
    queue<node>q,qq;
    s.x=n;
    s.step=0;
    int vis[100010]= {0};
    q.push(s);
    while (!q.empty())
    {
        s=q.front();
        q.pop();
        if (s.x==k)
            return s.step;
        for (int i=0; i<2; i++)
        {
            ss.x=s.x+dir[i];
            ss.step=s.step+1;
            if (ss.x>=0&&ss.x<=100000)
                if (!vis[ss.x])
                {
                    vis[ss.x]=1;
                    q.push(ss);
                }
        }
        ss.x=s.x*2;
        ss.step=s.step+1;
        if (ss.x>=0&&ss.x<=100000)
        {
            if (!vis[ss.x])
            {
                vis[ss.x]=1;
                q.push(ss);
            }
        }
    }
    return 0;
}


int main ()
{
    int n,k;
    while (~scanf("%d%d",&n,&k))
    {
        printf ("%d\n",bfs(n,k));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值