HDU 4460 Friend Chains(BFS)

Friend Chains

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4943    Accepted Submission(s): 1603


Problem Description
For a group of people, there is an idea that everyone is equals to or less than 6 steps away from any other person in the group, by way of introduction. So that a chain of "a friend of a friend" can be made to connect any 2 persons and it contains no more than 7 persons.
For example, if XXX is YYY’s friend and YYY is ZZZ’s friend, but XXX is not ZZZ's friend, then there is a friend chain of length 2 between XXX and ZZZ. The length of a friend chain is one less than the number of persons in the chain.
Note that if XXX is YYY’s friend, then YYY is XXX’s friend. Give the group of people and the friend relationship between them. You want to know the minimum value k, which for any two persons in the group, there is a friend chain connecting them and the chain's length is no more than k .
 

Input
There are multiple cases.
For each case, there is an integer N (2<= N <= 1000) which represents the number of people in the group.
Each of the next N lines contains a string which represents the name of one people. The string consists of alphabet letters and the length of it is no more than 10.
Then there is a number M (0<= M <= 10000) which represents the number of friend relationships in the group.
Each of the next M lines contains two names which are separated by a space ,and they are friends.
Input ends with N = 0.
 

Output
For each case, print the minimum value k in one line.
If the value of k is infinite, then print -1 instead.
 

Sample Input
  
  
3 XXX YYY ZZZ 2 XXX YYY YYY ZZZ 0
 

Sample Output
  
  
2
 题目大意:给出n个点m条边,求出所有任意两点间最短路的最大值。
思路:用BFS,求出每个点到其他所有点的最短路,最后遍历取最大值即可。
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<queue>
#include<set>
#include<map>
using namespace std;

const int maxn = 1000 + 10;
const int INF = 1e9+10;
map<string, int> ID;
vector<string> names;
int id, n, m, dist[maxn][maxn], vis[maxn];
vector<int> con[maxn];

int getID(string &s)
{
    if (ID.count(s)) return ID[s];
    else return ID[s] = id++;
}

void bfs(int s, int *d)
{
    queue<int> q;
    while(!q.empty()) q.pop();
    memset(vis, 0, sizeof vis);
    for (int i = 1; i <= n; i++) d[i] = INF;
    d[s] = 0;
    vis[s] = 1;
    q.push(s);
    while(!q.empty()) {
        int m = q.front(); q.pop();
        for (int i = 0; i < con[m].size(); i++) {
            int x = con[m][i];
            if (vis[x]) continue;
            vis[x] = 1;
            d[x] = d[m]+1;
            q.push(x);
        }
    }
}

int main()
{
    while(scanf("%d",&n) == 1 && n) {
        ID.clear();
        names.clear();
        for (int i = 1; i <= n; i++) con[i].clear();
        id = 1;
        string s;
        for (int i = 0; i < n; i++) {
            cin >> s;
            getID(s);
        }
        scanf("%d",&m);
        while(m--) {
            string s1,s2;
            cin >> s1 >> s2;
            int x = getID(s1), y = getID(s2);
            con[x].push_back(y);
            con[y].push_back(x);
        }
        for (int i = 1; i <= n; i++) bfs(i, dist[i]);
        int ans = -1;
        for (int i = 1; i <= n; i++)
            for (int j = i+1; j <= n; j++)
               ans = max(ans, dist[i][j]);
        printf("%d\n",ans == INF ? -1 : ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值