Parentheses Balance
Parentheses Balance |
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
-
(a)
- if it is the empty string (b)
- if A and B are correct, AB is correct, (c)
- if A is correct, (A ) and [A ] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.Output
A sequence of Yes or No on the output file.Sample Input
3 ([]) (([()]))) ([()[]()])()
Sample Output
Yes No Yes
Miguel Revilla
2000-08-14
#include <stdio.h>
int main()
{
int top,n;
char c,a[200];
scanf("%d",&n);
getchar();
while(n--)
{
top=0;
int flag=1;
while((c=getchar())&&c!='\n')
if(flag)
{
if(c=='(') a[top++]=')';
if(c=='[') a[top++]=']';
if(c==')')
{
top--;
if(a[top]!=c||top<0)
flag=0;
}
if(c==']')
{
top--;
if(a[top]!=c||top<0)
flag=0;
}
}
if(flag&&!top)printf("Yes\n");
else printf("No\n");
}
}