D - Doing Homework 【状态压缩+DP】

经过这题,彻底觉得状态压缩是个神奇又恐怖的东西。再说再说~
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3
Sample Output
2
Computer
Math
English
3
Computer
English
Math

Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the
word “English” appears earlier than the word “Math”, so we choose the first order. That is so-called alphabet order.

所有分析都在注释里了!

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long int 
#define INF 0x3f3f3f3f
#define Irish_Moonshine main
int T; int N;
const int maxn = 16;
struct node {
    char str[105];
    int dead_line;
    int day_cost;
}clas[maxn];
int dp[1 << maxn];
int pre[1 << maxn];
//int n;
//bool cmp(node x, node y)
//{
//
//}
//用二进制的位运算实现状态压缩
//对n份作业进项全排列,取出扣分最少的
//dp[i]表示记录完成作业状态为i时的信息
//某状态能做第i个作业条件是:a中作业i尚未完成,即a&i=0;
//如果两个状态都能到达dp[i],选择扣分最小的路径。
//如果扣分相同,选择字典序最小的,由于输入的时候是按照字典序进行输入,所以不必考虑!
void output(int status)
{
    if (status == 0)return;
    int t = 0;
    for (int i = 0; i < N; i++)
        if ((status&(1 << i)) != 0 && (pre[status] & (1 << i)) == 0)
        {
            t = i;
            break;
        }
    output(pre[status]);
    printf("%s\n", clas[t].str);
}
int Irish_Moonshine()
{

    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &N);
        for (int i = 0; i < N; i++)
        {
            scanf("%s", clas[i].str);
            scanf("%d%d", &clas[i].dead_line, &clas[i].day_cost);
        }
        for (int i = 0; i < (1 << N); i++)
        {
            dp[i] = INF;
        }
        dp[0] = 0;//并没有做作业
        for (int i = 0; i < (1 << N); i++)
        {
            for (int j = 0; j < N; j++)
            {
                if (i&(1 << j))//与完之后全是0,当前步骤没有新加作业,不需要操作
                    continue;
                int s = 0;
                for (int k = 0; k < N; k++)
                {
                    if (i&(1 << k))//新完成了某项未完成作业
                        s += clas[k].day_cost;//算花费
                }
                s += clas[j].day_cost;
                if (s > clas[j].dead_line)s = s - clas[j].dead_line;//额外花费
                else s = 0;
                if (dp[i | (1 << j)] > dp[i] + s)
                {
                    dp[i | (1 << j)] = dp[i] + s;
                    pre[i | (1 << j)] = i;
                }
            }
        }
        printf("%d\n", dp[(1 << N) - 1]);//n个1,作业全部完成
        output((1 << N) - 1);//递归输出
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值