D - Doing Homework HDU1074 ( 动态规划 + 状态压缩 )


D - Doing Homework
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 1074

Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.


Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.


Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.


Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3



Sample Output

2
Computer
Math
English
3
Computer
English
Math

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order. 

题目的意思给你n(n<=15)门课程,你要去完成每门课的作业,但是老师给你了完成的期限,超过期限每一天就会扣你一分。问你安排完成作业的顺序使扣分最小。

    第一次做状态压缩,参考分析:点击打开链接

dp[i]:表示到达状态i扣去的最小的分数,  sum[i]:表示到达状态i时过去的天数


#include<bits/stdc++.h>
using namespace std;
template<class T>inline T read(T&x)
{
    char c;
    while((c=getchar())<=32)if(c==EOF)return 0;
    bool ok=false;
    if(c=='-')ok=true,c=getchar();
    for(x=0; c>32; c=getchar())
        x=x*10+c-'0';
    if(ok)x=-x;
    return 1;
}
template<class T> inline T read_(T&x,T&y)
{
    return read(x)&&read(y);
}
template<class T> inline T read__(T&x,T&y,T&z)
{
    return read(x)&&read(y)&&read(z);
}
template<class T> inline void write(T x)
{
    if(x<0)putchar('-'),x=-x;
    if(x<10)putchar(x+'0');
    else write(x/10),putchar(x%10+'0');
}
template<class T>inline void writeln(T x)
{
    write(x);
    putchar('\n');
}
//-------ZCC IO template------
const int maxn=1<<20;
const double inf=999999999;
#define lson (rt<<1),L,M
#define rson (rt<<1|1),M+1,R
#define M ((L+R)>>1)
#define For(i,t,n) for(int i=(t);i<(n);i++)
typedef long long  LL;
typedef double DB;
typedef pair<int,int> P;
#define bug printf("---\n");
#define mod  100000000

struct node
{
    char name[150];
    int need;//需要几天来解决
    int length;//老师给的期限
}p[maxn];
int dp[maxn],pre[maxn],sum[maxn];

void to(int s)
{
    if(!s)return ;
    to(s^(1<<pre[s]));
    printf("%s\n",p[pre[s]].name);
}
int main()
{
    int T,n;
    read(T);
    while(T--)
    {
        read(n);
        For(i,0,n)
        {
            scanf("%s%d%d",p[i].name,&p[i].length,&p[i].need);
        }
        memset(sum,0,sizeof(sum));
        int N=1<<n;
        for(int i=1;i<N;i++)
        {
            dp[i]=inf;
            for(int j=0;j<n;j++)
            {
                int tmp=1<<j;if(!(tmp&i))continue;
                int reduce=sum[i^tmp]+p[j].need-p[j].length;
                if(reduce<=0)reduce=0;
                if(dp[i]>=reduce+dp[i^tmp])
                {
                    dp[i]=reduce+dp[i^tmp];
                    pre[i]=j;
                    sum[i]=p[j].need+sum[i^tmp];
                }
            }
        }
        writeln(dp[N-1]);to(N-1);
    }
    return 0;
}
























  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值