POJ 3370 Halloween treats【鸽巢原理】

Halloween treats
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8973 Accepted: 3230 Special Judge
Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year’s experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , … , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print “no sweets” instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0
Sample Output

3 5
2 3 4
Source

Ulm Local 2007

题意:给出N个数,随意找出几个使和恰好为C的倍数。

典型的鸽巢原理问题,并不需要什么输入挂。

类似于POJ 2235

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
#define ll long long int
#define INF  0x3f3f3f3f
const int maxn = 1e5 + 10;
int a[maxn];
int sum[maxn];
int vis[maxn];
int main()
{
    int n; int m;
    while (~scanf("%d%d", &m, &n) && n && m)
    {
        memset(a, 0, sizeof(a));
        memset(sum, 0, sizeof(sum));
        memset(vis, 0, sizeof(vis));
        int flag = 0, flag2 = 0;
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
        }
        for (int i = 1; i <= n; i++)
        {
            sum[i] = (sum[i - 1] + a[i]) % m;
            if (vis[sum[i]])
            {
                flag2 = i;
                break;
            }
            vis[sum[i]] = i;
            if (sum[i] == 0)
            {
                flag = i;
                break;
            }
        }
        if (flag)
        {
            //printf("%d\n", flag);
            for (int i = 1; i <= flag; i++)
            {
                if (i != 1)
                    printf(" ");
                printf("%d", i);
            }

        }
        else if (flag2)
        {
            //printf("%d\n", flag2 - vis[sum[flag2]]);
            for (int i = vis[sum[flag2]] + 1; i <= flag2; i++)
            {
                if (i != vis[sum[flag2]] + 1)
                    printf(" ");
                printf("%d", i);
            }
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值