2017 CCPC 秦皇岛 E - String of CCPC【规律】

BaoBao has just found a string of length consisting of ‘C’ and ‘P’ in his pocket. As a big fan of the China Collegiate Programming Contest, BaoBao thinks a substring of is “good”, if and only if ‘C’, and ‘P’, where denotes the -th character in string . The value of is the number of different “good” substrings in . Two “good” substrings and are different, if and only if .

To make this string more valuable, BaoBao decides to buy some characters from a character store. Each time he can buy one ‘C’ or one ‘P’ from the store, and insert the character into any position in . But everything comes with a cost. If it’s the -th time for BaoBao to buy a character, he will have to spend units of value.

The final value BaoBao obtains is the final value of minus the total cost of all the characters bought from the store. Please help BaoBao maximize the final value.

Input
There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer (), indicating the length of string .

The second line contains the string () consisting of ‘C’ and ‘P’.

It’s guaranteed that the sum of over all test cases will not exceed .

Output
For each test case output one line containing one integer, indicating the maximum final value BaoBao can obtain.

Sample Input
3
3
CCC
5
CCCCP
4
CPCP
Sample Output
1
1
1
Hint
For the first sample test case, BaoBao can buy one ‘P’ (cost 0 value) and change to “CCPC”. So the final value is 1 - 0 = 1.

For the second sample test case, BaoBao can buy one ‘C’ and one ‘P’ (cost 0 + 1 = 1 value) and change to “CCPCCPC”. So the final value is 2 - 1 = 1.

For the third sample test case, BaoBao can buy one ‘C’ (cost 0 value) and change to “CCPCP”. So the final value is 1 - 0 = 1.

It’s easy to prove that no strategies of buying and inserting characters can achieve a better result for the sample test cases.

题意:每次可以插入一个C或者P,花费是0,1,2,3…如此递增的。每个“CCPC”可视作一分。问可能出现的最高分数是多少。

分析:我们增加一个“P”至多可能增加一个新的“CCPC”。我们增加一个“C”,最多可以增加两个“CCPC”的同时减少一个“CCPC”,也相当于就加了一个。

所以,我们只需要考虑第一次插入操作就可以。
- 注意边界控制。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>

using namespace std;
const int maxn = 2e5+10;
char s[5]="CCPC";
char str[maxn];
char a[22];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        scanf("%s",str);
        int tmp=0;
        for(int i=0;i<=n;i++)
        {
            int cs=0;
            int ans1=0,ans2=0,ans3=0;
            for(int k=max((i-5),0);k<min(n,i+5);k++)
            {
                a[cs++]=str[k];
            }
            for(int j=0;j<cs-3;j++)
            {
                bool flag=1;
                for(int k=0;k<4;k++)
                {
                    if(a[j+k]!=s[k])
                        flag=0;
                }
                ans1+=(int)flag;
            }
            cs=0;
            for(int k=max(i-5,0);k<i;k++)
            {
                a[cs++]=str[k];
            }
            a[cs++]='P';
            for(int k=i;k<min(n,i+5);k++)
            {
                a[cs++]=str[k];
            }
            for(int j=0;j<cs-3;j++)
            {
                bool flag=1;
                for(int k=0;k<4;k++)
                {
                    if(a[j+k]!=s[k])
                        flag=0;
                }
                ans2+=(int)flag;
            }
            cs=0;
            for(int k=max(i-5,0);k<i;k++)
            {
                a[cs++]=str[k];
            }
            a[cs++]='C';
            for(int k=i;k<min(n,i+5);k++)
            {
                a[cs++]=str[k];
            }
            for(int j=0;j<cs-3;j++)
            {
                bool flag=1;
                for(int k=0;k<4;k++)
                {
                    if(a[j+k]!=s[k])
                        flag=0;
                }
                ans3+=(int)flag;
            }
            if((ans2>ans1)||(ans3>ans1))
            {
               tmp=1;
               break;
            }
        }
        int ans=0;
        for(int i=0;i<n-3;i++)
        {
            int flag=1;
            for(int j=0;j<4;j++)
            {
                if(str[i+j]!=s[j])
                    flag=0;

            }
            ans+=flag;
        }
        printf("%d\n",ans+tmp);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值