2017 CCPC 秦皇岛 M - Safest Buildings 【几何&概率】

PUBG is a multiplayer online battle royale video game. In the game, up to one hundred players parachute onto an island and scavenge for weapons and equipment to kill others while avoiding getting killed themselves. BaoBao is a big fan of the game, but this time he is having some trouble selecting the safest building.

There are buildings scattering on the island in the game, and we consider these buildings as points on a two-dimensional plane. At the beginning of each round, a circular safe area whose center is located at (0, 0) with radius will be spawned on the island. After some time, the safe area will shrink down towards a random circle with radius (). The whole new safe area is entirely contained in the original safe area (may be tangent to the original safe area), and the center of the new safe area is uniformly chosen within the original safe area.

The buildings covered by the new safe area is called the safe buildings. Given the radius of the safe areas and the positions of the buildings, BaoBao wants to find all the buildings with the largest probability to become safe buildings.

Input
There are multiple test cases. The first line of input contains an integer , indicating the number of test cases. For each test case:

The first line contains three integers (), and (), indicating the number of buildings and the radius of two safe circles.

The following lines each contains 2 integers and (), indicating the coordinate of the buildings. Here we assume that the center of the original safe circle is located at , and all the buildings are inside the original circle.

It’s guaranteed that the sum of over all test cases will not exceed 5000.

Output
For each test case output two lines.

The first line contains an integer , indicating the number of buildings with the highest probability to become safe buildings.

The second line contains integers separated by a space in ascending order, indicating the indices of safest buildings.

Please, DO NOT output extra spaces at the end of each line.

Sample Input
2
3 10 5
3 4
3 5
3 6
3 10 4
-7 -6
4 5
5 4
Sample Output
1
1
2
2 3

题意:绝地求生游戏题。给出许多建筑,和一个原始安全圈。然后再原始安全圈内部更新一个新的安全圈。求哪个或者哪些个建筑最容易成为安全的地方。题目保证所有建筑都在原始安全圈之内!

分析:如果 2r>=R ,存在完全安全区,如果 2r<R ,存在存活概率相同的安全区。此外,生存概率递减。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>

using namespace std;
const int maxn = 100+10;
struct node
{
    int s;
    int flag;
} a[maxn];
int dis(int x,int y)
{
    return x*x+y*y;
}
bool cmd(node a,node b)
{
    if(a.s!=b.s)
        return a.s<b.s;
    return a.flag<b.flag;

}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,R,r;
        scanf("%d %d %d",&n,&R,&r);
        for(int i=1; i<=n; i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            a[i].flag=i;
            a[i].s=dis(x,y);
        }
        sort(a+1,a+1+n,cmd);
        int cnt=0;
        int ans[maxn];


        if(R-2*r<=0)
        {
            int d=2*r-R;
            for(int i=1; i<=n; i++)
            {
                if(a[i].s<=d*d)
                {
                    cnt++;
                    ans[cnt]=a[i].flag;
                }
            }
        }
        if(cnt!=0)
        {
            printf("%d\n",cnt);
            sort(ans+1,ans+1+cnt);
            for(int i=1; i<=cnt; i++)
            {
                printf("%d%c",ans[i],i==cnt?'\n':' ');
            }
            continue;
        }

        for(int i=1;i<=n;i++){

            if(a[i].s<=(R-2*r)*(R-2*r)){
                ans[++cnt]=a[i].flag;
            }else{
                break;
            }
        }
        if(cnt!=0){
            printf("%d\n",cnt);
            sort(ans+1,ans+1+cnt);
            for(int i=1; i<=cnt; i++)
            {
                printf("%d%c",ans[i],i==cnt?'\n':' ');
            }
            continue;
        }

        int now=a[1].s;
        cnt++;
        for(int i=2; i<=n; i++)
        {
            if(a[i].s==now)
            {
                cnt++;
            }
            else
            {
                break;
            }
        }
        printf("%d\n",cnt);
        for(int i=1; i<=cnt; i++)
        {
            ans[i]=a[i].flag;
        }
        sort(ans+1,ans+1+cnt);
        for(int i=1; i<=cnt; i++)
        {
            printf("%d%c",ans[i],i==cnt?'\n':' ');
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值