PAT advanced-1102-Invert a Binary Tree (25分)【二叉树】

1102 Invert a Binary Tree (25分)

The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:
8
1 -
--
0 -
2 7
--
--
5-
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题目要求:
二叉树有结点0~N-1,输出反转之后的层次遍历序列和中序遍历序列。

思路:
反转即意味着每个结点的左右子树交换,在输出时将左右子树交换即可
【算法笔记上利用后序遍历将左右孩子交换,但其实不必进行交换,在输出时进行处理即可】
1.一般层次遍历是先将左孩子入队,再将右孩子入队,这里题目要求反转,则应先入队右孩子,再入队左孩子;
2.一般中序遍历的顺序是“左中右”,这里改为“右中左”即可
3.由于结点是直接用序号表示,所以可以用静态二叉树
4.在进行层次遍历和中序遍历时,函数传入的应该是根节点,parent[i]表示序号为i的结点的父亲结点,初始为-1

#include<iostream>
#include<queue>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 15;
int parent[maxn];
int n;
struct node {
	int lchild;
	int rchild;
	node() :lchild(-1), rchild(-1) {}
}Node[maxn];

void layer(int root)
{
	//cout << "layer" << endl;
	queue<int> q;
	q.push(root);
	int num = 0;
	while (!q.empty())
	{
		int top = q.front();
		q.pop();
		if (num > 0) cout << " ";
		cout << top;
		num++;
		if (Node[top].rchild > -1) q.push(Node[top].rchild);
		if (Node[top].lchild > -1) q.push(Node[top].lchild);
		
	}
	cout << endl;
}
int cnt = 0;
void invertin(int root)
{
	if (root == -1) return;
	invertin(Node[root].rchild);
	if (cnt > 0) cout << " ";
	cout << root ;
	cnt++;
	invertin(Node[root].lchild);	
}
int main()
{
	cin >> n;
	string sl, sr;
	memset(parent, -1, sizeof(parent));
	for (int i = 0; i < n; i++)
	{
		cin >> sl >> sr;
		if (sl != "-") { 
			parent[stoi(sl)] = i; 
			Node[i].lchild = stoi(sl);
		}
		if (sr != "-") {
			parent[stoi(sr)] = i;
			Node[i].rchild = stoi(sr);
		}
	}
	for (int i = 0; i < n ; i++)
	{
		if (parent[i] == -1)
		{
			layer(i);
			invertin(i);
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值