PAT (Advanced Level)-1102 Invert a Binary Tree

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

要求:反转二叉树 即 交换结点的左右孩子的值 层序遍历和中序遍历 输出二叉树 

#include <iostream>
#include <queue>
#include <vector>
using namespace std;

struct node
{
	int left,right;
};
vector<node>tree;
int book[10];
void invert(int r)
{
	if(r!=-1)
	{
		swap(tree[r].left,tree[r].right);
		invert(tree[r].left);
		invert(tree[r].right);
	}
}
void levelorder(int r)
{
	queue<int>queue;
	queue.push(r);
	while(!queue.empty())
	{
		int h=queue.front();
		printf("%s%d",book[h]?" ":"",h);
		queue.pop();
		if(tree[h].left!=-1)queue.push(tree[h].left);
		if(tree[h].right!=-1)queue.push(tree[h].right);		
	}
}
int flag;
void inorder(int r)
{
	if(r!=-1)
	{
		inorder(tree[r].left);
		printf("%s%d",flag?" ":"",r);
		flag=1;
		inorder(tree[r].right);
	}
}
int main()
{
	int n;
	scanf("%d",&n);
	tree.resize(n);
	for(int i=0;i<n;i++)
	{
		char lc,rc;
		cin>>lc>>rc;
		if(lc!='-')
		{
			tree[i].left=lc-'0';
			book[tree[i].left]=1;
		}
		else tree[i].left=-1;
		if(rc!='-')
		{
			tree[i].right=rc-'0';
			book[tree[i].right]=1;
		}
		else tree[i].right=-1;		
	}
	int root=0;
	while(book[root])root++;
	invert(root);
	levelorder(root);printf("\n");
	inorder(root);printf("\n");
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值