HDU 1372 骑士巡回问题

8 篇文章 0 订阅
Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
 

Input
The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".
 

Sample Input
  
  
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 
Sample Output
  
  
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.


这两天难得题目刷的我有些想吐...所以决定先看看简单的水题,这是直接套用广搜模板就可以过得题目。

广度搜索的意思大约也就是,我分身各朝着可以走的方向都先走一步的意思,谁先走到谁的步数就是最短路径。

#include <cstdio>
#include <queue>
#include <iostream>
#include <cstring>
using namespace std;
struct node{
    int x,y;
    int step;
};
queue<node>p;                        //广搜与深搜的区别就在这个队列,而不是用递归。
int pd[10][10];
int a[8]={ -1,1,2,2,1,-1,-2,-2};     //用a.b数组来控制每一步,要往哪里走。
int b[8]={ 2,2,1,-1,-2,-2,-1,1};

int bfs(int x1,int y1,int x2,int y2)
{
    node n;
    pd[x1][y1]=1;
    n.x=x1;
    n.y=y1;
    n.step=0;
    p.push(n);                      //输入的第一个坐标,先入队。

    while(!p.empty())               //循环来取接下来每步的位置
    {
        n=p.front();               
        p.pop();
        if(n.x==x2&&n.y==y2)return n.step;

        int aa,bb,st;
        for(int i=0;i<8;i++)
        {
            aa=n.x+a[i];
            bb=n.y+b[i];
            st=n.step;
            if(aa<1||aa>8||bb<1||bb>8)continue;   //两个条件判断,第一个判断是否出界,第二个判断是否走过了。
            if(pd[aa][bb]==1)continue;
            pd[aa][bb]=1;
            node m;
            m.x=aa,m.y=bb;
            m.step=st+1;

            p.push(m);             //走完的那一步要入队,因为还没有到终点。

        }
    }
    return 0;
}

int main()
{
    char c1[3],c2[3];

    while(scanf("%s %s",&c1,&c2)!=EOF)
    {
        int x1,x2,y1,y2;
        memset(pd,0,sizeof(pd));
        while(!p.empty())p.pop();
        x1=c1[0]-'a'+1,y1=c1[1]-'0';      //把数组中的坐标拆出来
        x2=c2[0]-'a'+1,y2=c2[1]-'0';
        printf("To get from %s to %s takes %d knight moves.\n",c1,c2,bfs(x1,y1,x2,y2));

    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值