Robberies(01背包)

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 3   Accepted Submission(s) : 1
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
 
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.
Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6
Source
IDI Open 2009
思路:
 01背包问题;
 我的解题过程:
  刚开始将被捕率当做背包体积消耗把它乘上100,把银行的钱当成是物品价值,其实这样解是错误的,
  因为被捕率不只是到0.01,其值精确更大,索要开的数组会很大,所以要装换一下思维
  正解:
  将银行的钱看成是背包的体积。求最大出逃率;
   f[j]=max(f[j],f[j-c[i]]*w[i])(w[i]为出逃率)
   然后从小大枚举找到符合条件的值
 
  */
#include <stdio.h>
#include <string.h>
#include <math.h>
#include<iostream>
using namespace std;
const int maxn=110;
double  f[10010];
double  w[110];
int c[110];
double  max(double  a,double  b)
{
    return a>b? a:b;
}
int main()
{
int T;
int i,j;
int n,s,m;
double p;
scanf("%d",&T);
while(T--)
{  scanf("%lf%d",&p,&n);
  memset(f,0,sizeof(f));
  s=0;
    for(i=0;i<n;i++)
    {
        scanf("%d%lf",&c[i],&w[i]);
        w[i]=1-w[i];//出逃率
        s+=c[i];
    }
    //printf("s=%d\n",s);
     f[0]=1;
    for(i=0;i<n;i++)
     for(j=s;j>=c[i];j--)
     {
        f[j]=max(f[j],f[j-c[i]]*w[i]);//求最大出逃率
     }
      for(i=0;i<=s;i++)//从小到大枚举数值
       { // printf("f[i]=%lf\n",f[i]);
           if(f[i]>=1-p)
             m=i;
       }
     printf("%d\n",m);
}
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值