poj1936

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 29582 Accepted: 12263

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No
题目大意就是判断后面那个字符串是否是前面那个字符串任意插入一些字符所构成的。
开始自己直接写的,测试数据过,提交不过,又套用的递归搜的也是如此,最后在poj讨论区里看人家的代码,简单易懂也ac,可是还是不造自己的错哪了,然后晚上找的同学看了人家发来的代码知道错哪了,开始我们的都一样,只是循环体处理的不一样,后来我的想法终于也过了,虽然代码比较挫吧
#include<stdio.h>
#include<string.h>
char s[100001],t[100001];
int main()
{
	int lens,lent,i,j,flag;
	while(~scanf("%s%s",s,t))
	{
		lens=strlen(s);
		lent=strlen(t);
		for(i=0,j=0;i<lens;++i)
		{
			flag=0;
			for(;j<lent;++j)
			{
				if(s[i]==t[j])
				{
					j++;break;//开始没加j++,没变量自增就直接跳出循环了。。。。
				}
				else if(j==lent-1)
				{
					flag=1;break;//我标记的是不可以的情况,处理的这里,同学处理的是上面的if语句,标记的可以的情况,其实都一样啦
				}
			}
			if(flag)
			{
				printf("No\n");
				break;
			}
		}
		if(!flag)printf("Yes\n");
	}
	return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值