Financial Management
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 178571 Accepted: 67213
Description
Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
Sample Output
$1581.42
Source
Mid-Atlantic 2001
#include <stdio.h>
int main (){
int i;
float n,s,sum;
for (i=1;i<=12;i++){
scanf("%f",&n);
sum+=n;
}
s=sum/12.0;
printf("$%.2f",s);
return 0;
}
主人公每个月有一定的钱,将12个月每月的钱分12行输入,再将12个月的平均值输出即可,要求输入每个月占一行,且数字前面无美元标志,输出时要在金钱前填上美元标志即可。
B题只需要用一个for循环满足输入,注意整除的性质,再注意格式输出即可