HDU 1029 Ignatius and the Princess IV

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 28417 Accepted Submission(s): 12033

Problem Description
“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.

Can you find the special integer for Ignatius?

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output
For each test case, you have to output only one line which contains the special number you have found.

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output
3
5
1

题意:输入一个非偶的数N,接下来一行输入N个数字,当某个数字重复 (N+1)/2,则输出这个数;
我写题目的经历:使用for 循环后,出现超时的情况,这类题目往往不能从简单的方面想,题目中说道有(N+1)/2次,不妨设变量count充当计数器,从极端角度看,当我所需的数与其他数间隔排布,如2 1 2 3 2 时,因为2是(N+1)/2次,故他的count>=1;从2 2 2 1 3 角度看,仍然成立,从1 3 2 2 2 角度看也成立—–想法源于寻找多元素算法
AC代码:

#include<stdio.h>
int main(){
    int n;
    while(~scanf("%d", &n)){
        int num,zzz;
        int count = 0;
        while(n--){
            scanf("%d", &num);
            if(count==0){
                zzz = num;
                count = 1;
            }
            else{
                if(zzz==num) count++;                   
                else count--;                    
            }
        }
        printf("%d\n",zzz);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值