Description
定义一个二维数组:
int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, };它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0 0 1 0 1 0 0 0 0 0 0 0 1 1 1 0 0 0 0 1 0
Sample Output
(0, 0) (1, 0) (2, 0) (2, 1) (2, 2) (2, 3) (2, 4) (3, 4) (4, 4)
AC Code
#include <iostream>
#include <string>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define inf 0x3f3f3f3f
struct queue{
int x;
int y;
int f;
}q[100];
void pr(int n) //递归输出
{
if(q[n].f==-1)
{
cout<<"(0, 0)"<<endl;
return;
}
else
{
pr(q[n].f);
cout<<'('<<q[n].x<<", "<<q[n].y<<')'<<endl;
}
return;
}
int main(int argc, char** argv) {
int i,j,map[6][6],book[6][6]={0},head,tail,flag,dir[][2]={{0,1},{0,-1},{-1,0},{1,0}};
for(i=0;i<5;i++)
for(j=0;j<5;j++)
{
cin>>map[i][j];
}
head=tail=0;
flag=0;
q[tail].x=q[tail].y=0;
q[tail].f=-1;
book[0][0]=1;
tail++;
while(head<tail) //bfs
{
int tx,ty;
for(i=0;i<4;i++)
{
tx=q[head].x+dir[i][0];
ty=q[head].y+dir[i][1];
if(tx<0||tx>4||ty<0||ty>4) continue;
if(book[tx][ty]==0&&map[tx][ty]==0)
{
book[tx][ty]=1;
q[tail].x=tx;
q[tail].y=ty;
q[tail++].f=head;
}
if(tx==4&&ty==4)
{
flag=1;
break;
}
}
if(flag)
break;
head++;
}
pr(tail-1);
return 0;
}