Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5 green red blue red red 3 pink orange pink 0
Sample Output
red pink
AC Code
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <queue>
#define inf 0x3f3f3f3f
#define MAXM 200005
#define MOD 10
using namespace std;
const double pi=3.141592653589793239,e=2.7182818284590452354;
typedef struct node{
int sum;
bool terminal;
struct node* next[26];
}*trie,node;
trie root;
void init_trie(trie &p)
{
p=(trie)malloc(sizeof(node));
p->sum=0;
p->terminal=0;
for(int i=0;i<26;i++)
{
p->next[i]=0;
}
return;
}
void insert(char str[])
{
int i=0;
trie p=root;
while(str[i]!='\0')
{
if(!p->next[str[i]-'a'])
{
trie q;
init_trie(q);
p->next[str[i]-'a']=q;
}
p=p->next[str[i]-'a'];
p->sum++;
i++;
}
p->terminal=1;
return;
}
int query(char str[])
{
int i=0;
trie p=root;
while(str[i]!='\0'&&p->next[str[i]-'a'])
{
p=p->next[str[i++]-'a'];
}
if(str[i]=='\0')
return p->sum;
else return 0;
}
int main(int argc, char** argv) {
int n;
while(cin>>n,n){
int i,id,m=0,tmp;
char str[1005][17];
init_trie(root);
for(i=0;i<n;i++)
{
cin>>str[i];
insert(str[i]);
}
for(i=0;i<n;i++)
{
tmp=query(str[i]);
if(tmp>m)
{
m=tmp;
id=i;
}
}
cout<<str[id]<<endl;
}
return 0;
}