HDU 1004 Let the Balloon Rise

ACM OJ题解目录
本题网址:https://cn.vjudge.net/problem/HDU-1004

Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
 
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
 
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
 
Sample Output
red
pink

题目大意:
  输入多组数据,每组数据的第一行是一个整数n,代表接下来数据的个数。
  接下来n行,输入的是一个字符串,代表一个颜色的单词。
  要求输出每组数据中颜色最多的颜色所代表的的字符串。
  输入以0结束
 
分析:
  用一个map<string, int>来存储,string就是颜色字符串,int代表它在这组数据中出现了几次。
  最后输出出现次数最多的即可。
  如果有map不会的同学,可自行百度,或者用一个结构体来代替。
  
代码如下:

#include <iostream>
#include <string>
#include <map>
using namespace std;

map<string, int> a;
string s;
int n;

int main()
{
	freopen("input.txt", "r", stdin);
	freopen("output.txt", "w", stdout);

	cin >> n;
	while (n)
	{
		a.clear();
		for (int i = 0; i < n; i++)
		{
			s.clear();
			cin >> s;
			map<string, int>::iterator it = a.find(s);
			if (it != a.end())
			{
				it->second++;	//如果存在,数量++
			}
			else
			{
				a.insert(make_pair(s, 1));	//如果不存在,插入一个
			}
		}

		int MAX = INT_MIN;
		for (map<string, int>::iterator it = a.begin(); it != a.end(); it++)
		{
			if (it->second > MAX)
			{
				MAX = it->second;
				s.clear();
				s = it->first;
			}
		}

		cout << s << endl;

		cin >> n;
	}

	system("pause");
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值