Frogs

Problem Description
There are  m  stones lying on a circle, and  n  frogs are jumping over them.
The stones are numbered from  0  to  m1  and the frogs are numbered from  1  to  n . The  i -th frog can jump over exactly  ai  stones in a single step, which means from stone  j mod m  to stone  (j+ai) mod m  (since all stones lie on a circle).

All frogs start their jump at stone  0 , then each of them can jump as many steps as he wants. A frog will occupy a stone when he reach it, and he will keep jumping to occupy as much stones as possible. A stone is still considered ``occupied" after a frog jumped away.
They would like to know which stones can be occupied by at least one of them. Since there may be too many stones, the frogs only want to know the sum of those stones' identifiers.
 

Input
There are multiple test cases (no more than  20 ), and the first line contains an integer  t ,
meaning the total number of test cases.

For each test case, the first line contains two positive integer  n  and  m  - the number of frogs and stones respectively  (1n104, 1m109) .

The second line contains  n  integers  a1,a2,,an , where  ai  denotes step length of the  i -th frog  (1ai109) .
 

Output
For each test case, you should print first the identifier of the test case and then the sum of all occupied stones' identifiers.
 

Sample Input
  
  
3 2 12 9 10 3 60 22 33 66 9 96 81 40 48 32 64 16 96 42 72
 

Sample Output
  
  
Case #1: 42 Case #2: 1170 Case #3: 1872
 
思路: 设GCD(a,m)=k,则a青蛙跳过的石头一定是k的倍数;我们可以枚举m的因子;标记所有整除a的因子;然后再用容斥定理求解:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long long q[20000],p[10000];
long long GCD(long long x,long long y)
{
    long long a,b;
    a=x>=y?x:y;
    b=x<=y?x:y;
    do
    {
        x=b;
        b=a%b;
        a=x;
    }while(b);
    return a;
}
int main()
{
    long long t,n,m,a,sum,cnt,d;
    scanf("%lld\n",&t);
    for(int o=1;o<=t;o++)
    {
        sum=0,cnt=0;
        scanf("%lld %lld",&n,&m);
        p[cnt++]=1;
        memset(q,0,sizeof(q));
        for(int i=2;i*i<=m;i++)
        {
            if(m%i==0)
            {
                if(i*i==m)
                    p[cnt++]=i;
                else
                {
                    p[cnt++]=i;
                    p[cnt++]=m/i;
                }
            }
        }
        sort(p,p+cnt);
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a);
            a=GCD(a,m);
            for(int j=0;j<cnt;j++)
                if(p[j]%a==0)
                q[j]=1;
        }
        for(int i=0;i<cnt;i++)
        if(q[i]!=0)
        {
            long long h=(m-1)/p[i];
            sum=sum+(h+1)*h/2*p[i]*q[i];
            for(int j=i+1;j<cnt;j++)
                if(p[j]%p[i]==0)
                q[j]=q[j]-q[i];
        }
        printf("Case #%d: %lld\n",o,sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值