1020 Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

代码如下:

#include<bits/stdc++.h>
using namespace std;
const int maxn = 50;
int  n, pos[maxn], ino[maxn], tree[100000];
void build_tree(int l, int r, int L, int R, int p)
{
    if(l > r)
        return ;
    tree[p] = pos[R];
    for(int i = l; i <= r; i++)
        if(ino[i] == tree[p])
        {
            build_tree(l, i - 1,L , L + i - l - 1, p << 1);
            build_tree(i + 1, r, L + i - l, R - 1, p << 1 | 1);
            break;
        }
}
int main()
{
    ios::sync_with_stdio(false);
    memset(tree, -1, sizeof(tree));
    cin >> n;
    for(int i = 0; i < n; i++)
        cin >> pos[i];
    for(int i = 0; i < n; i++)
        cin >> ino[i];
    build_tree(0, n - 1, 0 , n - 1, 1);
    int cnt = 1, i = 2;
    cout << tree[1];
    while(cnt < n)
    {
        if(tree[i] != -1)
        {
            cout << " "<< tree[i];
            cnt++;
        }
        i++;
    }
    cout << endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值