Counting Leaves

1004 Counting Leaves (30)(30 分)

A family hierarchy is usually presented by a pedigree tree. Your job isto count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a linecontaining 0 < N < 100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in theformat:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K isthe number of its children, followed by a sequence of two-digit ID's ofits children. For the sake of simplicity, let us fix the root ID to be01.

Output

For each test case, you are supposed to count those family members whohave no child for every seniority level starting from the root. Thenumbers must be printed in a line, separated by a space, and there mustbe no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is theroot and 02 is its only child. Hence on the root 01 level, there is 0leaf node; and on the next level, there is 1 leaf node. Then we shouldoutput "0 1" in a line.

Sample Input

2 1
01 1 02

Sample Output

0 1
题目大意: 从根节点开始算等级,输出每一等即没有孩子的家庭成员;
思路:先建树,用vis判断有无孩子,查找每个人所在的等级,并记为le[i],计算等级为i没有孩子的数目s[i];

代码如下:

#include<bits/stdc++.h>
using namespace std;
int pa[110],vis[110],le[110],s[110];//vis[0]代表没有孩子,le计算i的等级,s计算等级为i的没有孩子的数目;
int root(int r)
{
    int l=0;
    while(pa[r]!=r)
    {
        r=pa[r];
        l++;
    }
    return l;
}
int main()
{
    int n,m,maxn=0;
    cin>>n>>m;
    for(int i=0;i<=99;i++)
        pa[i]=i;
    memset(vis,0,sizeof(vis));
    while(m--)
    {
        int a,b;
        cin>>a;
        int k;
        cin>>k;
        while(k--)
        {
            cin>>b;
            pa[b]=a;
            vis[a]=1;
        }
    }
    for(int i=1;i<=n;i++)
    {
        le[i]=root(i);
        maxn=max(maxn,le[i]);
    }
    for(int i=1;i<=n;i++)
        if(!vis[i])
            s[le[i]]++;
    cout<<s[0];
    for(int i=1;i<=maxn;i++)
        cout<<" "<<s[i];
    cout<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值