ZOJ 1195 Blowing Fuses

Maybe you are familiar with the following situation. You have plugged in a lot of electrical devices, such as toasters, refrigerators, microwave ovens, computers, stereos, etc, and have them all running. But at the moment when you turn on the TV, the fuse blows, since the power drawn from all the machines is greater than the capacity of the fuse. Of course this is a great safety feature, avoiding that houses burn down too often due to fires ignited by overheating wires. But it is also annoying to walk down to the basement (or some other inconvenient place) to replace to fuse or switch it back on.

What one would like to have is a program that checks before turning on an electrical device whether the combined power drawn by all running devices exceeds the fuses capacity (and it blows), or whether it is safe to turn it on.


Input

The input consists of several test cases. Each test case describes a set of electrical devices and gives a sequence of turn on/off operations for these devices.

The first line of each test case contains three integers n, m and c, where n is the number of devices (n <= 20), m the number of operations performed on these devices and c is the capacity of the fuse (in Amperes). The following n lines contain one positive integer ci each, the consumption (in Amperes) of the i-th device.

This is followed by m lines also containing one integer each, between 1 and n inclusive. They describe a sequence of turn on/turn off operations performed on the devices. For every number, the state of that particular devices is toggled, i.e. if it is currently running, it is turned off, and if it is currently turned off, it will by switched on. At the beginning all devices are turned off.

The input will be terminated by a test case starting with n = m = c = 0. This test case should not be processed.


Output

For each test case, first output the number of the test case. Then output whether the fuse was blown during the operation sequence. The fuse will be blown if the sum of the power consumptions ci of turned on devices at some point exceeds the capacity of the fuse c.

If the fuse is not blown, output the maximal power consumption by turned on devices that occurred during the sequence.

Output a blank line after each test case.


Sample Input

2 2 10
5
7
1
2
3 6 10
2
5
7
2
1
2
3
1
3
0 0 0


Sample Output

Sequence 1
Fuse was blown.

Sequence 2
Fuse was not blown.

Maximal power consumption was 9 amperes.

题目大意:有一堆电器,给出他们的功率,然后依次对他们进行操作(开或者关,取决于之前状态),判断是否超过保险丝的容量。

分析:定义两个数组分别存电器的功率和他的当前状态,然后模拟每一次操作,当前关,则打开,当前打开,则关掉。

注意格式问题。

#include <stdio.h>
#include<memory.h>
int p[21];//设备功率
int s[21];//status,状态
int main()
{
    int a,b,c;
    int num=1;
    while(scanf("%d %d %d",&a,&b,&c)&&a&&b&&c)
    {
    int i;
    for(i=1;i<=a;i++)
        scanf("%d",&p[i]);
    memset(s,0,sizeof(s));//很重要!
    int sum=0;
    int max=0;
    for(i=0;i<b;i++)
    {
        int x;
        scanf("%d",&x);
        if(s[x])
        {
            s[x]=0;
            sum-=p[x];
        }
        else
        {
            s[x]=1;
            sum+=p[x];
        }
        if(max<sum)
            max=sum;
    }
    printf("Sequence %d\n",num++);
    if(max>c)
        printf("Fuse was blown.\n");
    else
    {
        printf("Fuse was not blown.\n");
        printf("Maximal power consumption was %d amperes.\n",max);
    }
    printf("\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎曼猜想·

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值