ZOJ 1241 Geometry Made Simple

Mathematics can be so easy when you have a computer. Consider the following example. You probably know that in a right-angled triangle, the length of the three sides a, b, c (where c is the longest side, called the hypotenuse) satisfy the relation a*a+b*b=c*c. This is called Pythagora's Law.

Here we consider the problem of computing the length of the third side, if two are given.

Input

The input contains the descriptions of several triangles. Each description consists of a line containing three integers a, b and c, giving the lengths of the respective sides of a right-angled triangle. Exactly one of the three numbers is equal to -1 (the 'unknown' side), the others are positive (the 'given' sides).

A description having a=b=c=0 terminates the input.


Output

For each triangle description in the input, first output the number of the triangle, as shown in the sample output. Then print "Impossible." if there is no right-angled triangle, that has the 'given' side lengths. Otherwise output the length of the 'unknown' side in the format "s = l", where s is the name of the unknown side (a, b or c), and l is its length. l must be printed exact to three digits to the right of the decimal point.

Print a blank line after each test case.


Sample Input

3 4 -1
-1 2 7
5 -1 3
0 0 0


Sample Output

Triangle #1
c = 5.000

Triangle #2
a = 6.708

Triangle #3

Impossible.

分析:给出直角三角形三边a,b,c(c为斜边),题目中给出任意两条边,求另外一条。未知的边用-1表示即可。

纯粹的Pythagora's Law.,毕达哥拉斯定理,即勾股定理。

在格式问题上又困扰了很久,忽略了空格,肉眼完全看不出来,必须复制题设中的样例进行观察。

AC代码:

#include <stdio.h>
#include <math.h>
int main()
{
    double a,b,c;
    int cnt=1;
    while(scanf("%lf %lf %lf",&a,&b,&c)&&a&&b&&c)
    {
        printf("Triangle #%d\n",cnt++);
        if(c!=-1&&(a>c||b>c))
           {
            printf("Impossible.\n\n");
            continue;
           }
        else if(a==-1)
            printf("a = %.3lf\n\n",sqrt(c*c-b*b));
        else if(b==-1)
            printf("b = %.3lf\n\n",sqrt(c*c-a*a));
        else
            printf("c = %.3lf\n\n",sqrt(a*a+b*b));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎曼猜想·

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值