Poj 1003

水题。

看别人都说水题。。 我写了一个多小时emmmmm,最后发现是二分查找的退出条件少了个等号。。

一.描述

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

二.分析

n张卡片最终会得到 1/2 + 1/3 + .... + 1/(n+1)的长度,现在反过来,给出一个长度(float)c,询问n最小是多少,才能让和项S(n)>=c



关键的一点是在输入描述的地方给出了c的一个范围,这决定了,n实际上是有一个上界的,对于多次查询的情况,考虑将迭代的结果储存在一个数组中,用查询的方式给出
答案,用空间换取时间

三.二分查找应用的讨论
数组查找!!可以搞一个二分查找来提高效率,尽管这个数组很小,不二分找其实也绰绰有余,但是emmmm
二分查找要考虑到的一个问题是,我们很可能是找不到最终的结果的,我们首先对小于等于0.5的情况返回1,那么会有 a[1] < c < a[Max_n] 的保证,所以我们可以进行
二分查找, 在没能找到的时候,进行回溯,找到符合条件的下标: 考虑以下的几种情况


考虑到 a[1] < c < a[Max_n]
(1)
  如果 |(c-a[index])|< 1e-6 => index 就是结果
(2)
  如果不存在(1)的情况,那么
  a[1] =< a[i] < c < a[j] <= a[Max_n]
  
  考虑 low...i c j.....hig 的情况(low==1, hig==Max_n的情况蕴含在以下讨论中了)
  
  a)  如果 a[mid] > c: hig = mid - 1;
  we get:
       low...i c j..... hig 和当前情况相同
       
       low...i c hig  之后的更新mid将总是比j小,也就是说a[mid] 总是小于c,这将会使得low不断增大,直到low==hig,此时a[mid]=a[hig]>c
       因此我们做更新:hig = mid - 1,退出循环,此时的正确答案应该是low使得a[low]>=c 且low是最小的满足这个不等式的答案
        
  b)  如果 a[mid] < c: low = mid + 1;
  we get:
      low...i c j....hig 和当前情况相同
    
      low c j...hig 之后如果hig不等于j的话,mid将总是比i大,这导致a[mid]>c,使得hig不断减小,直到hig==j,此时a[mid]=a[i]<c
       因此我们做更新:low = mid+1,则low = hig =j, 且a[mid]==a[j]>c,做更新hig=mid-1=i,退出循环,此时的正确答案应该是low使得a[low]>=c;
 
 所以,采用二分查找,如果c<=0.5,返回1
                  如果找到,返回mid 

                   否则,返回low

四.源代码

#include <iostream>
#include <cmath>
int binSearch(float record[], int low, int hig, float c);
const float eps = 1e-6f;
int main()
{
	using namespace std;
	float record[277];
	float sum = 0;
	for (int n = 1; n <= 276; ++n) {
		sum += 1.0f / (n+1);
		record[n] = sum;
	}
	cin >> sum;
	while (sum >= 0.01 && sum <= 5.20) {
		cout << binSearch(record, 1, 276, sum) << " card(s)" << endl;
		cin >> sum;
	}
	return 0;
}

int binSearch(float record[], int low, int hig, float c)
{
	if (c <= 0.5)
		return 1;
	int mid = (low + hig) / 2;
	while (low <= hig) {
		if (c < record[mid])
			hig = mid - 1;
		else if (c > record[mid])
			low = mid + 1;
		else
			break;
		mid = (low + hig) / 2;
	}
	if (fabs(c - record[mid]) < eps)
		return mid;
	return low;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值