1047 Student List for Course (25分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:
For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:
10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5
Sample Output:
1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

也是一对多的问题,可以直接map解决,map<int,vector>或者map<int,set>都可以,但是set是自动排序的,vector的话需要sort一下。
但是set的insert时间复杂度是O(n),push_back的时间复杂度为O(1)
但是重点是要用printf和scanf,不要用cin和cout。
string和printf还有scanf都是命里犯冲的,如果需要输入string,那就要定义一个字符数组,char c[5],然后通过scanf(:"%s",c)来输入,不用&
string s;
如果是输出就更有难度了,需要printf("%s",s.c_str()),string也不能直接输出的,需要通过c_str()函数
但是这道题测试点1就是过不了,查了百度,应该是如果一门课没有人选,那么map自然没有这门课,也就什么都输出不了,然后事实是,我们需要这门课名称和人数0
所以换了一种方法,用二维数组。

#include<iostream>
#include<vector>
#include<map>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
    int n, k;
    map<int, vector<string>> ma;
    scanf("%d%d",&n,&k);
    char name[5];
    int num,course;
    for(int i = 0; i < n; i++){
        scanf("%s %d",name, &num);
        for(int j = 0; j < num; j++){
            scanf("%d",&course);
            ma[course].push_back(name);
        }
    }
    for(auto it = ma.begin(); it != ma.end(); it++){
        vector<string> name = it->second;
        printf("%d %d\n",it->first,name.size());
        sort(name.begin(), name.end());
        for(int i = 0; i < it->second.size();i++){
            printf("%s\n", name[i].c_str());
        }
    }
    return 0;
}

要先k赋值,才能给vector一个初始大小
可以先输入char数组,char c[5]
然后再定义string类型的变量时,直接初始化变量。string str©)

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
    int n, k;
    scanf("%d%d",&n,&k);
    vector<string> ma[k+1];
    int num,course;
    for(int i = 0; i < n; i++){
        char temp[5];
        scanf("%s %d",temp, &num);
        string name(temp);
        for(int j = 0; j < num; j++){
            scanf("%d",&course);
            ma[course].push_back(name);
        }
    }
    for(int i = 1; i <= k; i++){//因为课程编号是从1-K的
        int size = ma[i].size();
        sort(ma[i].begin(),ma[i].end());
        printf("%d %d\n",i,size);
        for(int j = 0; j < size; j++){
            printf("%s\n",ma[i][j].c_str());
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值