[PAT A1047]Student List for Course

[PAT A1047]Student List for Course

题目描述

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

输入格式

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

输出格式

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

输入样例

10 5

ZOE1 2 4 5

ANN0 3 5 2 1

BOB5 5 3 4 2 1 5

JOE4 1 2

JAY9 4 1 2 5 4

FRA8 3 4 2 5

DON2 2 4 5

AMY7 1 5

KAT3 3 5 4 2

LOR6 4 2 4 1 5

输出样例

1 4

ANN0

BOB5

JAY9

LOR6

2 7

ANN0

BOB5

FRA8

JAY9

JOE4

KAT3

LOR6

3 1

BOB5

4 7

BOB5

DON2

FRA8

JAY9

KAT3

LOR6

ZOE1

5 9

AMY7

ANN0

BOB5

DON2

FRA8

JAY9

KAT3

LOR6

ZOE1

解析

  1. 题目大意是输入n,k,n表示学生的个数,k表示所有的课程的数目,接下来n个输出,对于每个输出,首先输出学生的姓名,然后输出该学生选的课程的数目,接下来输入该学生所选的课程的id。
  2. 然后对于每一个课程(编号1~k),首先输出课程id,然后输出该课程选的学生的数目,接下来每行输出一个选该课程的学生的姓名,并且按照字符串升序输出。
  3. 这道题目就是考察STL的使用,和上次一样,我使用string还是没能通过全部样例,最后通过阅读了晴神和柳神的代码,自己写出了程序,使用了char数组通过了最后一组数据,具体解析放在代码块里。
  4. #include<iostream>
    #include<vector>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    const int maxn = 40010; //学生的最大人数
    const int maxc = 2510;  //课程的最大数
    char name[maxn][5];     //这里数组必须开到5,因为char数组赋值的时候,会自动在尾部添加\0,我由于经常使用string,所以对char数组使用很少,调试的时候遇到了这个问题
    vector<int> course[maxc];
    bool cmp(int a,int b) //自己写cmp函数
    {
    	return strcmp(name[a], name[b]) < 0;
    }
    int main()
    {
    	int n, k;
    	scanf("%d%d", &n, &k);
    	for (int i = 0; i < n; i++) {
    		int num, temp;
    		scanf("%s %d", name[i], &num);
    		for (int j = 0; j < num; j++) {
    			scanf("%d", &temp);
    			course[temp].push_back(i);
    		}
    	}
    	for (int i = 1; i <= k; i++) sort(course[i].begin(), course[i].end(), cmp);
    	for (int i = 1; i <= k; i++) {
    		printf("%d %d\n", i, course[i].size());
    		for (int j = 0; j < course[i].size(); j++) 
    			printf("%s\n", name[course[i][j]]);
    	}
    	return 0;
    }

     

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值