1048 Find Coins (25分)

25 篇文章 0 订阅

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10
​5
​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10
​5
​​ , the total number of coins) and M (≤10
​3
​​ , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the two face values V
​1
​​ and V
​2
​​ (separated by a space) such that V
​1
​​ +V
​2
​​ =M and V
​1
​​ ≤V
​2
​​ . If such a solution is not unique, output the one with the smallest V
​1
​​ . If there is no solution, output No Solution instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

这道题就是让你在一串数字中找出和为某个特定值的一对数字,因为直接用暴力法会超时,而且它要求输出v1比较小的,那么在无序的情况下,输出完一对不能保证v1比较小。
所以先对其进行sort,这样还能用双指针了,因为它是递增序列,所以另i = 0, j = n -1,如果v[i]+v[j]小于目标值,证明i要++,因为j已经在最大值上了,反之–,直到i >= j,因为你不可以同一个数字取两次,而且如果i > j也没必要

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
    int n, needPay, value[100001];
    cin>>n>>needPay;
    for(int i = 0; i < n; i++){
        cin>>value[i];
    }
    int pay;
    sort(value,value + n);
    for(int i = 0, j = n -1; i < j;){
        pay = value[i] + value[j];
        if(pay == needPay){
            cout<<value[i]<<" "<<value[j];
            return 0;
        }
        if(pay < needPay){
            i++;
            continue;
        }
        else{
            j--;
            continue;
        }
    }
    cout<<"No Solution";
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值