1082 Read Number in Chinese (25分)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.

Input Specification:
Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:
For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai

主要思路是分节输出

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main(){
    string a;
    string num[11] = {"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
    string wei[11] = {"Shi","Bai","Qian","Wan","Yi"};
    cin>>a;
    if(a[0] == '-'){
        a = a.substr(1);
        cout<<"Fu ";
    }
    int len = a.length();
    int left = 0, right = len - 1;
    while(left + 4 <= right){
        right -= 4;
    }
    while(left < len){//循环每次处理数字的一节(4位或小于4位)
        bool flag = false;//flag = false表示没有累计的的0
        bool isPrint = false;//isPrint = false表示该节没有输出过其中的位
        while(left <= right){//从左往右处理数字中某节的每一位
            if(left > 0 && a[left] == '0'){//如果当前位为0
                flag = true;//令标记flag为true
            }
            else{//如果当前位不为0
                if(flag == true){//如果存在累积的0
                    printf(" ling");
                    flag = false;
                }
                //只要不是首位,后面的每一位前都要输出空格
                if(left > 0) printf(" ");
                printf("%s",num[a[left] - '0'].c_str());//输出当前位数字
                isPrint = true;//该节至少有一位被输出
                if(left != right){//某节中除了个数外,都需要输出十百千
                    printf(" %s", wei[right - left - 1].c_str());
                }
            }
            left++;//left右移1位
        }
        if(isPrint == true &&right != len - 1){//只要不是个位,就输出万和亿
            printf(" %s",wei[(len - 1- right) / 4 + 2].c_str());
        }
        right += 4;//right右移4位,输出下一节
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值