1089 Insert or Merge (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6

主要是分别模拟一遍插入排序和归并排序。

#include<cstdio>
#include<algorithm>
using namespace std;
const int N = 111;
int origin[N], tempOri[N], changed[N];//原始数组,原始数组备份,目标数组
int n;//元素个数

bool isSame(int A[], int B[]){//判断数组A和数组B是否相同
    for(int i = 0; i < n; i++){
        if(A[i] != B[i]) return false;
    }
    return true;
}

bool showArray(int A[]){
    for(int i = 0; i < n; i++){
        if(i!=0) printf(" ");
        printf("%d",A[i]);
    }
    printf("\n");
}

bool insertSort(){//插入排序
    bool flag = false;//如果有相同的就直接返回true
    //默认第一位是有序的,所以从第一位开始排序,每次将一位数字插入前面的序列中
    for(int i = 1 ; i < n; i++){
        if(i != 1 && isSame(tempOri, changed)){
            flag = true;//中间步骤与目标相同,且不是初始序列
        }
        int temp = tempOri[i], j = i;//从当前数字的前面一位开始比,如果比当前数字大,证明还要向前,大的那一位往后移,给它空一个位置
        while(j > 0 && tempOri[j - 1] > temp){
            tempOri[j] = tempOri[j - 1];
            j--;
        }
        tempOri[j] = temp;//如果找到j-1号位比temp小,证明找到了,把它插在j-1的后面一位
        if(flag == true){
            return true;
        }
    }
    return false;//归并排序完成还没找到
}

void mergeSort(){//归并排序
    bool flag = false;//记录是否存在数组中间步骤与changed数组相同
    //以下为归并排序部分
    for(int step = 2; step / 2<= n; step *= 2){
        if(step != 2 && isSame(tempOri, changed)){
            flag = true;
        }
        for(int i = 0; i < n; i += step){
            sort(tempOri + i, tempOri + min(n, i +step));
        }
        if(flag == true){
            showArray(tempOri);
            return;
        }
    }
}

int main(){
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        scanf("%d", &origin[i]);//输入起始数组
        tempOri[i] = origin[i];//tempOri数组为备份,排序过程在tempOri上进行
    }
    for(int i = 0; i < n; i++){
        scanf("%d", &changed[i]);//目标数组
    }
    if(insertSort()){//如果在插入排序中找到目标数组
        printf("Insertion Sort\n");
        showArray(tempOri);
    }
    else{//到达此处时一定是归并排序
        printf("Merge Sort\n");
        for(int i = 0; i < n; i++){
            tempOri[i] = origin[i];//还原tempOri数组
        }
        mergeSort();//归并排序
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值