1149 Dangerous Goods Packaging (25分)

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10
​4
​​ ), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] … G[K]
where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:
For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:
6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333
Sample Output:
No
Yes
Yes

一开始用map来存,然后全错,仔细看题发现居然每个物品可能有多种不兼容的物品,所以用二维数组来存。输入ship数组后,for循环判断即可,有一组不兼容就false

#include<iostream>
#include<vector>
using namespace std;
int main(){
    int n,m;
    vector<int> bad[100000];//bad[1]是一个vector,下面存了它不能共存的物品
    cin>>n>>m;
    int u,v;
    for(int i = 0; i < n; i++){
        cin>>u>>v;
        bad[u].push_back(v);
        bad[v].push_back(u);
    }
    int k;
    int ship[1005];
    for(int i = 0; i < m; i++){
        cin>>k;
        bool flag = true;
        for(int j = 0; j < k; j++){
            cin>>ship[j];
        }
        for(int j = 0; j < k; j++){
            for(int l = j + 1; l < k; l++){
                for(int p = 0; p <bad[ship[j]].size(); p++){
                    if(bad[ship[j]][p] == ship[l]) flag = false;
                }
            }
        }
        if(flag == false) cout<<"No\n";
        else cout<<"Yes\n";
    }
    return 0;
}

一开始差点用map<int,vector>来存,还好没有,双重for下面还要再嵌套一个遍历vector的太过分了。所以后面用unordered_set来存不合适的物品更好,直接用j去findl,如果找的到就是no,因为有些物品没有被记录,所以在查找每个物体是否有不合适的物品前,先在map里find这个物品,如果找不到,证明它和谁都合适,直接continue。如果没有这一步会超时。比二维数组快得多得多。二维数组也不错,每个物品下面是一个vector

#include<iostream>
#include<cstdio>
#include<unordered_set>
#include<unordered_map>
using namespace std;
int main(){
    int n,m;
    cin>>n>>m;
    int u,v;
    unordered_map<int,unordered_set<int>> ma;//每一个货物下面存着不能和其共存的物品们
    for(int i = 0; i < n; i++){
        cin>>u>>v;
        ma[u].insert(v);
        ma[v].insert(u);
    }
    int k;
    int good[1005];
    for(int i = 0; i < m; i++){
        cin>>k;
        bool flag = true;
        for(int j = 0; j < k; j++){
            cin>>good[j];
        }
        for(int j = 0; j < k; j++){
            if(ma.find(good[j]) == ma.end()) continue;
            for(int l = j + 1; l < k; l++){
                if(ma[good[j]].find(good[l]) != ma[good[j]].end()){
                    flag = false;
                    break;
                }
            }
            if(flag == false) break;
        }
        if(flag == false) cout<<"No\n";
        else cout<<"Yes\n";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值