1153 Decode Registration Card of PAT (25分)

A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10
​4
​​ ) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.

Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

排序,不难,最后两个超时

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
#include<unordered_map>
using namespace std;
struct node{
    string card;
    char level;
    string site;
    string date;
    string number;
    int score;
}nodes[10001];


struct siteNum{
    string site;
    int num;
};

bool cmp1(node a, node b){
    if(a.score != b.score) return a.score > b.score;
    else return a.card < b.card;
}

bool cmp2(siteNum a, siteNum b){
    if(a.num != b.num) return a.num > b.num;
    else return a.site < b.site;
}

int main(){
    int n,m;
    cin>>n>>m;
    string card;
    int score;
    for(int i = 0; i < n ; i++){
        cin>>card>>score;
        nodes[i].card = card;
        nodes[i].level = card[0];
        nodes[i].site = card.substr(1,3);
        nodes[i].date = card.substr(4,6);
        nodes[i].number = card.substr(10,3);
        nodes[i].score = score;
    }
    int q;
    char level;
    string site;
    string date;
    for(int i = 1; i <= m; i++){
        cin>>q;
        vector<node> temp;
        vector<siteNum> ans;
        unordered_map<string,int> ma;
        bool flag = true;
        if(q==1){
            cin>>level;
            for(int j = 0; j < n; j++){
                if(nodes[j].level == level){
                    temp.push_back(nodes[j]);
                }
            }
            sort(temp.begin(),temp.end(),cmp1);
            printf("Case %d: %d %c\n",i,q,level);
            if(temp.size() == 0) cout<<"NA\n";
            else{
                for(int j = 0; j < temp.size(); j++){
                    printf("%s %d\n",temp[j].card.c_str(),temp[j].score);
                }
            }
        }
        else if(q==2){
            cin>>site;
            int cnt = 0, sum = 0;
            for(int j = 0; j < n; j++){
                if(nodes[j].site == site){
                    cnt++;
                    sum += nodes[j].score;
                }
            }
            printf("Case %d: %d %s\n",i,q,site.c_str());
            if(cnt == 0) cout<<"NA\n";
            else{
                printf("%d %d\n",cnt,sum);
            }
        }
        else if(q == 3){
            cin>>date;
            int cnt = 0;
            bool siteFlag = false;
            for(int j = 0; j < n; j++){
                if(nodes[j].date == date){
                    siteFlag = true;
                    ma[nodes[j].site]++;
                }
            }
            for(auto it:ma) ans.push_back({it.first,it.second});
            sort(ans.begin(),ans.end(),cmp2);
            printf("Case %d: %d %s\n",i,q,date.c_str());
            if(siteFlag == false) cout<<"NA\n";
            else{
                for(int j = 0; j < ans.size(); j++){
                    printf("%s %d\n",ans[j].site.c_str(),ans[j].num);
                }
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值