Surprising Strings

Surprising Strings

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the “Puzzling Adventures” column in the December 2003 issue of Scientific American.

Input
The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output
For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input
ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*
Sample Output
ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

题意:首先按照间隔为0个字母找,例如ZGBG,间隔为0时,为ZG,GB,BG,没有相同字符串,然后按照间隔为1个字母找,ZB,GG,也没有相同字符串,在按照间隔为2的字符串找,ZG,只有一个字符串,所以没有跟他相同的,也没有间隔为3即以上的字符了,所以他为surprising
题解:将每个字符串利用map进行哈希,观察该字符串是否出现过,如果出现过,则为not surprising,否则,surprising

#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<cstring>
#include<vector>
using namespace std;
map<string, int>::iterator it;

int main()
{
	string s;
	string end = "*";
	while (cin >> s, s != end)
	{
		if (s.size() < 3)
		{
			cout << s << " is surprising." << endl;
			continue;
		}
		else
		{
			map<string, int>mp;
			string res;
			int f = 1;
			for (int i = 0; i < s.size(); i++)
			{
				for (int j = 0; i + j < s.size() - 1; j++)
				{
					res += s[j];
					res += s[i + j + 1];
					mp[res]++;
					res.clear();
				}
				for (it = mp.begin();it != mp.end();it++)
				{
					if (it->second > 1)
					{
						f = 0;
						break;
					}
				}
				mp.clear();
				if (!f)break;
			}
			
			if (f) cout << s << " is surprising." << endl;
			else cout << s << " is NOT surprising." << endl;
		}
	}
	return 0;
}
  • 5
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Ja_King_ZH

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值