HDU 1712 ACboy needs your help(分组背包入门题)2021-08-13

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from
different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. N = 0 and M = 0 ends the input.

Output
For each data set, your program should output a line which
contains the number of the max profit ACboy will gain.

Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output
3
4
6

题意:一个学生有M天的复习时间,要学N门课程,学习每门课程收获的价值与学习的天数有关。问学生复习M天能够收获的最大价值。

将N 门课程看作N组物品,将每门课程不同的学习天数j看作每组物品中的第j个物品,j也相当于物品所占的体积。

不同的课程学习不同的天数能得到不同的价值。

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

const int N = 100+10;
int matr[N][N];
int dp[N];
int main()
{
    int n,m;
    while(cin>>n>>m)
    {
        memset(dp,0,sizeof(dp));
        memset(matr,0,sizeof(matr));
        if(!n&&!m) break;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
            cin>>matr[i][j];/*复习第i种科目时间达到第j天得到的价值*/
        for(int i=1;i<=n;i++)
            for(int j=m;j>=0;j--)
                for(int k=1;k<=m;k++)
                if(j>=k) dp[j]=max(dp[j],dp[j-k]+matr[i][k]);
        cout<<dp[m]<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值