每日一题----动态规划背包问题HDU1712

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13530    Accepted Submission(s): 7335


 

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
 
 
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
 
 
3 4 6
 

Source

这是一个经典的动态规划问题。ACboy需要安排他的学习时间来最大化利润。

首先,我们创建一个二维数组dp[N+1][M+1],其中dp[i][j]表示前i门课程,在j天内取得的最大利润。

然后,进行初始化,将dp[0][j]和dp[i][0]都设置为0(0 <= j <= M,0 <= i <= N)。

接下来,我们使用动态规划的递推关系来计算dp[i][j]的值。对于每门课程i(1 <= i <= N)和天数j(1 <= j <= M),我们可以选择在前一门课程中花费k天(0 <= k <= j)来完成当前课程。因此,我们可以得到以下递推关系:

dp[i][j] = max(dp[i][j], dp[i-1][j-k] + A[i][k])

最终的答案是dp[N][M],即在N门课程中花费M天所能获得的最大利润。

#include<iostream>
using namespace std;
const int maxn = 102;
int c[maxn],w[maxn][maxn],dp[maxn];
int n,m;
int main()
{
	while(~scanf("%d%d",&n,&m),n&&m){
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++){
			scanf("%d",&w[i][j]);
		}
		fill(dp,dp+maxn,0);
		for(int i=0;i<n;i++){
			for(int j=m;j>0;j--)
			{
				for(int k=0;k<j;k++){
					dp[j]=max(dp[j],dp[j-k-1]+w[i][k]);
				}
			}
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

善程序员文

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值