动态规划To the Max

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 


0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0
9 2 -6 2
-4 1 -4  1
-1 8  0 -2

Sample Output

15

题目大意:求最大矩阵子段和

可以通过把二缩到一维,考虑一维最大子段和问题,给出一个序列啊a[0],a[1],a[2]...a[n],求连续的一段,使其

总和最大。dp[i]表示以a[i]结尾的子段和

dp[i] = max(a[i],dp[i-1]+a[i])

当dp[i]>0时,则dp[i] = dp[i-1]+a[i]

当dp[i-1]<0时,则dp[i] = a[i]

代码如下

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#define MAXN 101
using namespace std; 
int MaxArry(int n,int arr[]){//一行最大子段和
	int sum=0,max=0;
	for(int i=1;i<=n;i++){
		if(sum>0){
			sum+=arr[i];
		}else{
			sum=arr[i];
		}
		if(sum>max){
			max = sum;
		}
	}
	return max;
} 
int MaxMat(int n,int a[][MAXN]){
	int max = a[1][1];
	int sum;
	int temp[MAXN];
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++){
			temp[j]=0;
		}
		for(int j=i;j<=n;j++){
			for(int k=1;k<=n;k++){
				temp[k]+=a[j][k];
			}
			sum = MaxArry(n,temp);
			if(sum>max){
				max = sum;
			} 
		}
	}
	return max;
}
int main(){
	int n;
	int arr[MAXN][MAXN];
	int max;
	while(~scanf("%d",&n)){
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++){
				cin>>arr[i][j];
			}
		}
		max = MaxMat(n,arr);
		cout<<max<<endl;
		
		
		
		
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值