How to Type
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 7153 Accepted Submission(s): 3230
Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3 Pirates HDUacm HDUACM
Sample Output
8 8 8HintThe string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
可以使用两个数组来分别保存两种数据
一种表示之前没按Caps lock
另一种表示按了Caps lock
如注释所示::
#include <bits\stdc++.h>
using namespace std;
const int maxn=105;
char s[maxn];
int off[maxn],on[maxn]; //on表示之前按过caps lock的左边,off表示caps lock已经成对出现
int main(int argc,char *argv[])
{
// freopen("data.in.txt","r",stdin);
int ncase;
cin>>ncase;
while(ncase--){
cin>>s+1;
off[0]=0;
on[0]=1;
int ans;
for(int i=1;s[i];i++){
if(s[i]>='a'&&s[i]<='z'){
off[i]=min(off[i-1]+1,on[i-1]+2);//off的直接加上一个字符,on加上字符及关上的caps lock
on[i]=min(off[i-1]+2,on[i-1]+2);//off的加上关上的caps lock或shift外加一个字符,on加上关上的caps lock加上一个字符
}
else{
off[i]=min(off[i-1]+2,on[i-1]+2);//表示off先加上一个shift再加上字符,on加上一个字符再加上右侧的caps lock
on[i]=min(off[i-1]+2,on[i-1]+1);// 表示off先加一个字符,再加一个左边的caps lock,on只要直接加上字符
}
ans=i;
}
cout<<min(off[ans],on[ans]+1)<<endl;
}
return 0;
}