hdu 2577(DP)

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 

这道题目我开始的想法是:dp[i][j]表示第i个字符,用方式j打出来,其中j = 0表示直接打出来,因为是小写,j = 1是用shift,j=2是用Caps Lock。。看起来很简单,但是有一个陷阱很容易忽略。。。Caps Lock变亮时,按下shift后可以打出小写字母。。。。太坑了。。。之前定义的状态就不好表示了。。。

WA:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int inf = 0x3f3f;
int dp[101][3];
char str[101];

int main()
{	
	int t;
	scanf("%d",&t);
	while(t--)
	{
		getchar();
		scanf("%s",str);
		int len = strlen(str);
		memset(dp,inf,sizeof(dp));
		if(str[0] >= 'A')
			dp[0][1] = dp[0][2] = 2;
		else dp[0][0] = 1;
		for(int i = 1; i < len; i++)
		{
			if(str[i] >= 'A' && str[i] <= 'Z')	//当前字符为大写
			{
				if(str[i-1] >= 'A' && str[i-1] <= 'Z')
				{
					dp[i][1] = min(dp[i][1],dp[i-1][1] + 2);
					dp[i][1] = min(dp[i][1],dp[i-1][2] + 3);
					dp[i][2] = min(dp[i][2],dp[i-1][1] + 2);
					dp[i][2] = min(dp[i][2],dp[i-1][2] + 1);
				}
				else
				{
					dp[i][1] = dp[i-1][0] + 2;
					dp[i][2] = dp[i-1][0] + 2;
				}
			}
			else
			{
				if(str[i-1] >= 'A' && str[i-1] <= 'Z')
				{
					dp[i][0] = min(dp[i][0],dp[i-1][1] + 1);
					dp[i][0] = min(dp[i][0],dp[i-1][2] + 2);
				}
				else
					dp[i][0] = dp[i-1][0] + 1;
			}
		}
		if(str[len-1] >= 'A' && str[len-1] <= 'Z')
			printf("%d\n",min(dp[len-1][1],dp[len-1][2]+1));
		else printf("%d\n",dp[len-1][0]);
	}
	return 0;
}

借鉴了别人的思路,写了一个能AC的代码:

#include<cstring>
#include<cstdio>
int dp[110][10];
int min(int a,int b)
{
    if(a>b)
        return b;
    return a;
}
int main()
{
    char str[10010];
    int s,sum,i,j,k1,k2;
    int t;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        gets(str);
        s=sum=strlen(str);
        dp[0][0]=0;
        dp[0][1]=1;
        for(i=0;str[i]!='\0';i++)
        {
           if(str[i]>='A'&&str[i]<='Z')
           {
                dp[i+1][1]=min(dp[i][0]+2,dp[i][1]);
                dp[i+1][0]=min(dp[i][0]+1,dp[i][1]+1);
            }
           else
           {
                dp[i+1][1]=min(dp[i][0]+1,dp[i][1]+1);
                dp[i+1][0]=min(dp[i][0],dp[i][1]+2);
           }
       }
       int ans=min(dp[s][1]+1,dp[s][0]);
       printf("%d\n",ans+s);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值