1013 Battle Over Cities (25分)

1013 Battle Over Cities (25分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

这道题有两种做法:并查集和DFS

1.并查集

 思路比较简单:把除被占领的城市之外的城市,按照所输入的连通关系(比如1 2;1 3;类似的)全部Union到一起,最后遍历的时候查一共有多少个父亲结点,最后的总数-2即可。为什么要减2呢?因为要除去被占领的城市这个结点(n-1),剩下的n-1个结点如果要连通的话需要(n-1)-1=n-2条路,即为答案。

#include<cstdio>
#include<vector>
#include<utility>
using namespace std;
int n;
int father[1005];
vector<pair<int,int>>v;
void init()
{
    for(int i=0;i<n;i++)
        father[i]=i;
}
int findFather(int x)
{
    int a=x;
    while(father[x]!=x){
        x=father[x];
    }
    while(a!=father[a]){
        int z=a;
        a=father[a];
        father[z]=x;
    }//路径压缩!否则会超时!
    return x;
}
void Union(int a,int b)
{
    int A=findFather(a);
    int B=findFather(b);
    if(A!=B)
        father[A]=B;
}


int main() {
    int m,k;
    scanf("%d%d%d",&n,&m,&k);
    for(int i=0;i<m;i++){
        int a,b;
        scanf("%d%d",&a,&b);
        v.push_back(make_pair(a,b));
    }
    for(int i=0;i<k;i++){
        init();
        int q;
        scanf("%d",&q);
        int sum=0;
        for(int j=0;j<v.size();j++){
            if(v[j].first!=q&&v[j].second!=q){
                Union(v[j].first,v[j].second);//除了这个被占领的城市(q)之外,其余的都按照输入连通
            }
        }
        for(int j=0;j<n;j++){
            if(father[j]==j)
                sum++;
        }
        printf("%d\n",sum-2);
    }
    return 0;
}

 2.DFS(参考柳神)

思路:在已经建立好的图中,把被攻占的城市设为已访问(vis[i]=1),即不再访问这个结点(城市);剩下的"零散"的子图,每DFS一次便将子图数sum+1(sum初始为0)(其中要格外注意:访问过的点要设为vis=1,不能重复访问)最后连通这些子图需要sum-1条路。

#include<cstdio>
#include<algorithm>
using namespace std;
int G[1005][1005];
bool vis[1005]= {false};
int n;
void DFS(int node) {
    vis[node]=true;
    for(int i=1; i<=n; i++) {
        if(!vis[i]&&G[node][i]==1)
            DFS(i);
    }
}
int main() {
    int m,k;
    scanf("%d%d%d",&n,&m,&k);
    for(int i=1; i<=m; i++) {
        int a,b;
        scanf("%d%d",&a,&b);
        G[a][b]=G[b][a]=1;
    }
    for(int i=1; i<=k; i++) {
        int q;
        int sum=0;
        scanf("%d",&q);
        fill(vis,vis+1005,false);//这句不能落下,每次查询都必须初始化
        vis[q]=true;
        for(int j=1; j<=n; j++) {
            if(vis[j]==false) {
                DFS(j);
                sum++;
            }
        }
        printf("%d\n",sum-1);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值